Clamscan will not shut down

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 27.1.3
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04
Apache or nginx version (eg, Apache 2.4.25): Apache
PHP version (eg, 7.4): 8.1.2

The issue you are facing:
Clamscan is maxing out my processors on Nextcloud server. I turned off the Antivirus app in Nextcloud but that didn’t affect it. I turned the app back on, but now it is running a second instance of clamscan. Not sure how I can disable it from running or if there is a way to control it better.

You could simply uninstall clamav:

sudo apt-get remove *clamav* clamdscan

or if you prefer to keep it on your server, you can stop the services running on your server:

sudo systemctl stop clamav-daemon clamav-freshclam

… this will stop the services but they will be started after next reboot. You can disable the services so that they do not start automatically:

sudo systemctl disable clamav-daemon clamav-freshclam

If you later at one point want to reenable the clamav services:

sudo systemctl enable clamav-daemon clamav-freshclam

Much luck,
ernolf

Thanks I just needed to do the shut down for now but this helped me do that.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.