Chron/Ajax failing to run after upgrade to v20


I have been running NextCloud for some time on shared hosting. Despite the limitations from my provider, it has been working pretty well.

However, I recently realized that I had fallen far out of date (v16–yikes!). Upgrading to v16 was such a nightmare, I had been putting it off. However, I decided to upgrade to v20 by stepping through each major version. It seemed to have worked, but a few days later, I started getting alerts that the periodical jobs were not running. I think I originally had it set to use cron (I hope so), but don’t remember for certain. “It just worked” for quite some time. Well, now it doesn’t. It had defaulted to Ajax, so I switched to over to cron, thinking that should fix the issue, but it didn’t. It looks like it ran once after I switched it over, and not again.

Keep in mind, I have almost zero CLI access on the server. I can technically run bash commands on the server, but am quite limited in that regard. I can also use the OCC Web app for some OCC needs.

Any suggestions?

Thanks in advance!