Changing config.php don't take effekt, I think ('shared_folder')

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): `24.0.2
Operating system and version (eg, Ubuntu 20.04): Linux 5.15.46-Unraid x86_64
Apache or nginx version (eg, Apache 2.4.25): idk
PHP version (eg, 7.4): idk
I am using the docker container for UnRAID, also using mariaDB,

The issue you are facing:

Trying to add ‘shared_folder’ => ‘/delt_med_meg’, to config.php to make a folder for shared elements, but that folder is not showing up in GUI, not even for new shares shared after the edit, and I have also tried to restart container, not working eiher.

Is this the first time you’ve seen this error? (Y/N): kind of, tried multiple times

Steps to replicate it:

  1. edit config.php
  2. save file

The output of your Nextcloud log in Admin > Logging:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'datadirectory' => '/data',
  'instanceid' => 'XXX',
  'passwordsalt' => 'XXX',
  'secret' => 'XXX',
  'trusted_domains' =>
  array (
    0 => 'nextcloud.XXX',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://nextcloud.XXX',
  'dbname' => 'nextcloud',
  'dbhost' => '',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => 'XXXl',
  'installed' => true,
  'maintenance' => false,
  'loglevel' => 2,
  'shared_folder' => '/delt_med_meg',

                                           [ R

The output of your Apache/nginx/system log in /var/log/____:

error.log is empty

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

can’t find that

root@afc0ef83b766:/var/www# ls

Have you set the correct rights for the folder and all subdirs and subfiles?
E.g. chown -R www-data:www-data /delt_med_meg
Also check the rights of the mountpoint.
Is in this folder the correct substructure e.g. dirs like usernames, …

Like this?

root@afc0ef83b766:/data# ls
__groupfolders  annlan                chrfag  files_external  jaresp   krinil  marlun  natbjo         rinhan  stehol  trihau
admin           appdata_ocljftos5uyp  chrsol  fleska          jesrig   kriwaa  maydav  nextcloud.log  sammos  suzmil  trimyh
agnben          audvil                dannyg  freing          jonjon   leiaza  minzar  olesla         samses  terosm  updater-ocljftos5uyp
alegul          belsam                dombuk  index.html      julrob   linwit  morkro  olilar         sarroc  tersal  updater.log
alfsor          cecska                eirrye  janbre          kenkjea  lotnyg  morsve  riksol         silfro  thonyg

Also, I have not made any real folder, is that even necessary?

Hi @flemmingss

There is a typo in your config. The correct parameter would be: 'share_folder' without the “d”

And yes your assumption that only things shared with you after the change in config.php will show up in it is correct. But you can manually move files to it that were previously shared with you.

No it’s not. But afaik the folder only appears after someone has shared something with you, after you made the change in config.php

The typo was my only mistake :stuck_out_tongue: works now

1 Like