Can't write into config directory! This can usually be fixed by giving the webserver write access to the config directory

I’m new to LINUX and just finished installing Linux Mint 18.3 Cinnamon with no problems. I wanted to put apache2 with mysql on the linux platform so I installed with bitnami and everything is working. (opt/lampp folder) However, when I attempt Nextcloud (not a bitnami package) into the htdocs folder I receive:

Can’t write into config directory!
This can usually be fixed by giving the webserver write access to the config directory.

I’ve tried to add users and groups and set 775, 777 and nothing seems to make any difference. Do I need to install somewhere else?

Does anyone know which file needs to be corrected to get past this problem?

The pho is 5.6.33; processor is Intel-i5; hdd partition has about 100gb with a swap space. I’ve tried Nextcloud 12 and it requires php7 so I gave up. The previous version has the same error.

If it is a bitnami thing does anyone know where to get answers, or should I simply install a different apache2/mysql package?


Can you provide the output of
ls -al opt/lampp/nextcloud

If that is not the correct folder, please adjust to your environment.
What I would expect here is, that the folder nextcloud/config is missing write permissions. That folder contains the config.php which stores the important configurations for Nextcloud.

Hey thx! I finally got it working but honestly I don’t have all the permissions and paths fully understood.

I simply deleted all the files except the config and data folders from an old “owncloud” Bitnami installation. [opt/lamp/apps/owncloud] A lot of the confusion is that Bitnami installs separately from the htdocs folder I typically use. Anyway, simply moving all new folders from a virgin copy of NextCloud 11 into the “htdocs” folder within the “opt/lampp/apps/owncloud/” folder and then running “occ” from the browser eventually worked. My nextcloud version needed (prompted during update) another column in the “oc_accounts” table called “uid”. So after adding that, with phpmyadmin, the upgrade worked.

The whole thing seems messy… I still cannot get a standalone version to work outside of Bitnami.

I’m using Linux Mint 18.3 Cinnamon. I really like the performance and the interface, but, I wish for less terminal use and more gui… it’s just quicker.