Can't use newly installed NextCloud with FreeNAS

Attempted to Install the NextCloud v20 plugin in FreeNAS 11.3-RELEASE-p14, but when I edit the config.php file, I get page not found.

That was using DHCP. I tried installing the plugin with NAT, but it also has page not found when trying to click the manage button.

This is the tutorial I followed. He just clicked management, and it worked. Not sure what I’m doing wrong. I had it working perfectly before, but had to reinstall the plugin…

Error I’m getting:
chrome_ZN9LrO9gk3

I can get past the error page by changing it from https to http, but I still can’t connect to the actual app. It just gets stuck trying to log in. It also doesn’t ask me to setup the DB when I first login, so maybe some data is left over from my last install? Any ideas?

1 Like

I’m currently having the same issue. I’m on FreeNAS-11.3-U5 trying to install v20 of Nextcloud. If I install it with the default selections(NAT) it installs, but I cannot reach the management page. If I change it to DHCP, it installs and I can get to the management page, but when I edit the config.php file for Trusted Domains I lose connectivity(in the way you describe), even after a restart of the plugin. If I try to install the plugin with static IP with or without VNET it fails to install entirely. So far, I am unable to get a working install of the plugin after trying several things.

I started looking into this issue on their github https://github.com/nextcloud/server/issues/17409

Can’t figure how if this is going to help or not, and I don’t know where to try adding that overwriteprotocol

I know it is old-fashioned in times of Youtube an Co. but searching/reading the administrator guide as first step helps in most cases :wink: