Can't upgrade to v20 from v19

Nextcloud version (eg, 18.0.2): 19.0.4
Operating system and version (eg, Ubuntu 20.04): linuxserver docker container
Apache or nginx version (eg, Apache 2.4.25): not sure
PHP version (eg, 7.1): not sure

The issue you are facing:

I keep seeing emails that nextcloud v20 has been released. Wonderful!

So when I try to upgrade using the updater and check under the settings menu, it says I am already on the latest version?

$ docker exec -it nextcloud updater.phar --no-interaction
Nextcloud Updater - version: v19.0.3-8-gbfdc40b

Current version is 19.0.4.

No update available.

Nothing to do.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Attempt to upgrade

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


The output of your Apache/nginx/system log in /var/log/____:


Hello @obbardc,

please use the search function here or with your preferred search engine next time.

Please see:

1 Like

Right, I think this should this be clearer in the update script though. Because it’s not really true :wink:

you have to stop the container, get a new image and start a new container.

Yep, my workflow is to: pull a new image, recreate the container then update using the nextcloud updater.
It’s in a script and runs automated weekly :wink:

you are using the “official” nextcloud images? the nextcloud images check during startup if the version needs an update.

Hi together,
Just found this discussion as I have exactly the same issue.
Like obbardc, at least as I´m understood, I use the container “linuxserver/nextcloud”.

Would be great when someone has a solution or at least an idea about what could be tried.

How do you force this upgrade if you are not running nextcloud in a container? I have it installed on it’s own, but I get the same thing when I try to run the update.


Hi together,
I believe we were all just to impatient.

At least I had a few days ago the possibility to upgrade to 19.0.5 first and directly after it offered the upgrade to 20.x.

Yes, upgrade all worked fine today! Had to upgrade to 19.0.5 for a day until the upgrade to 20.x was offered :slight_smile: