Can't upgrade NC17 to NC18.0.1 Wrong SQL create options

Start update? [y/N] y

Info: Pressing Ctrl-C will finish the currently running step and then stops the updater.

[:heavy_check_mark:] Check for expected files
[:heavy_check_mark:] Check for write permissions
[:heavy_check_mark:] Create backup
[:heavy_check_mark:] Downloading
[:heavy_check_mark:] Verify integrity
[:heavy_check_mark:] Extracting
[:heavy_check_mark:] Enable maintenance mode
[:heavy_check_mark:] Replace entry points
[:heavy_check_mark:] Delete old files
[:heavy_check_mark:] Move new files in place
[:heavy_check_mark:] Done

Update of code successful.

Should the “occ upgrade” command be executed? [Y/n] y
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
2020-02-16T16:29:05+00:00 Set log level to debug
2020-02-16T16:29:05+00:00 Repair step: Repair MySQL collation
2020-02-16T16:29:05+00:00 Repair info: All tables already have the correct collation -> nothing to do
2020-02-16T16:29:05+00:00 Repair step: Repair SQLite autoincrement
2020-02-16T16:29:05+00:00 Repair step: Copy data from accounts table when migrating from ownCloud
2020-02-16T16:29:06+00:00 Repair step: Drop account terms table when migrating from ownCloud
2020-02-16T16:29:06+00:00 Updating database schema
2020-02-16T16:29:09+00:00 Doctrine\DBAL\Exception\DriverException: An exception occurred while executing ‘CREATE TABLE oc_direct_edit (id BIGINT AUTO_INCR
EMENT NOT NULL, editor_id VARCHAR(64) NOT NULL, token VARCHAR(64) NOT NULL, file_id BIGINT NOT NULL, user_id VARCHAR(64) DEFAULT NULL, share_id BIGINT DEFAULT NULL, timestamp BIGINT UNSIGNED NOT NULL, accessed TINYINT(1) DEFAULT ‘0’ NOT NULL, INDEX IDX_4D5AFECA5F37A13B (token), PRIMARY KEY(id)) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_bin ENGINE = InnoDB ROW_FORMAT = compressed’:

SQLSTATE[HY000]: General error: 1005 Can’t create table nextcloud.oc_direct_edit (errno: 140 “Wrong create options”)
2020-02-16T16:29:09+00:00 Update failed

Ok the problem was that i had compression enabled by default for the whole database.

innodb_compression_default = 0

1 Like