Cant Update NextCloudPi version

On the web interface I cant update Nextcloudpi. After I click on update It shows a red dot and nothing happens. Also my version on the top left is set to 0.0.0.
I can see the version under SystemInfo its 15.0.5.3

I tried to update via ncp-config but it says
file /usr/local/bin/ncp/TOOLS/nc-update.sh
/usr/local/bin/ncp/UPDATES/nc-update.sh not found

Hi and
Thanks for reporting.
Which image are you using and can you post link here, to pastebin (or similar), with output of ncp-report?

nextcloudpi debian

https://pastebin.com/W9HAFa2n

I seem to have a similar problem. I only noticed because my lets encrypt expired, and I couldtnt get it to renew. I tried to update NC and NCP and it wont let me. I get the same error as awkscp.

Just in case it is related, the letsencrupt error is;

[ letsencrypt ]
/usr/local/bin/ncp/NETWORKING/letsencrypt.sh: line 57: /usr/bin/letsencrypt: No such file or directory

Is there a fix?

Devs are working on fixing issues with updating from very old images. Expecting it with one of upcoming releases.

unfortunately the fix won’t work for such old images, but from now on people can be more lazy updating and updates won’t break

Just managed to update, and also renew letsencrypt.

Thanks to everyone involved

How did you update it?

I managed to update from version 15 to 16 through nextcloud web interface settings page.