Can't sync a W10 mapped drive from desktop client


Is the W10 Nextcloud client not capable of syncing mapped drives ? If yes, then what am I doing wrong ? Please see below:

  • I have a fully functional nextcloud instance in the cloud.
  • I am trying to select a folder on the Z: drive of my W10 Nextcloud desktop client, to sync it with that remote nexcloud.
  • If I try a c: folder on the client, it works perfectly, but it fails if I try with a Z: drive folder on the same w10 PC.
  • The Z: drive is mapped to a NAS shared folder on the LAN. I can create and delete files in every Z: folders from the W10 file explorer.
  • However, in Nextcloud desktop, when I try to add that Z: drive folder to sync it, it keeps telling me I have no permission to write on that Z: drive folder. It does display its content in the file explorer dialog where I am supposed to pick the to-be-synced folder (from within the Nextcloud client), and indeed, I can’t delete or create file from that file explorer dialog. This is weird because I can from the W10 file explorer.
  • The same behavior happens with a UNC path instead of mapped drive.
  • I tried several NAS shared folders, same result.

I searched for a few hours and could not find anything about this behavior.

Thank you in advance for your insights…


Solved here: Nextcloud Client - local folder on windows network drive based on a synology share - write permission