Can't start update through updater


#1

I run nextcloud on a share host.

When I start updater, nexcloud displays the page here after and I don’t know how to proceed. Can anybody help ?

Authentication

To login you need to provide the unhashed value of “updater.secret” in your config file.

If you don’t know that value, you can access this updater directly via the Nextcloud admin screen or generate your own secret:

php -r '$password = trim(shell_exec("openssl rand -base64 48"));if(strlen($password) === 64) {$hash = password_hash($password, PASSWORD_DEFAULT) . "\n"; echo "Insert as \"updater.secret\": ".$hash; echo "The plaintext value is: ".$password."\n";}else{echo "Could not execute OpenSSL.\n";};' Invalid password


#2

This problem also occurred to me when trying to update from 15.0.0 to 15.0.2


#3

Same problem on a share host with PHP 7.1 from 14.0.4 to 15.0.2


#4

+1 | upgrade 15.0.2 > 15.0.4 | :confused:
These steps solved it:

  • open server console and run suggested command php -r '$password = trim(shell_exec(… (OpenSSL must be installed)
  • It returns two values
    • updater.secret write into the config.php
    • fill the web field with the plaintext value

(Nevertheless my upgrade failed at 6 step with error “Parsing response failed”. I’ve completed upgrade manually with these instructions)