Can't share via facebook in socialsharing

i dunno if i’m in the correct thread to post my problems with socialsharing, especially facebook. so if not please feel free to move this post over to the correct thread.

i’m running nc 12.0.2 [updated]
php 7.0.19
mysql 10.1.23
on a raspi 3, raspbian 8

and i can’t share anything using the facebook-button/entry. there is an errormessage in an extra window which roughly translates as:
URL can’t be loaded: Domain of this URL isn’t available within app. To be able to load the app enter all domains and subdomains of your app at appdomain-field in your app-setup.
(original “Kann URL nicht laden: Die Domain dieser URL ist nicht in den Domains der App vorhanden. Um diese URL laden zu können, füge alle Domains und Subdomains deiner App im Appdomain-Feld in deinen App-Einstellungen hinzu.”)

bug or feature? or where can i, myself, enter said domains to make it run?

cc @rullzer


could you, jason, please do me a favour and try if you could share something to facebook with your demo-instance… would you be so kind, please?

like go to e.g. nc-manual share - link - share to facebook. i couldn’t finish it with your demo-instance. if it’ll work for you i’d then’ll know that it maybe was a problem with my browser or such. if you won’t be able to share to fb as well, i know that i’m not alone and so it could be a bug with nc 12.

thank you very much in advance


Works here :+1:

1 Like

thanks. so somehow my standard-browser hast to be the problem… as i use firefox.
again: thanks a bazillion times :slight_smile:

1 Like

i’m a bit further… i used a chromium-browser to try sharing. and the popup got loaded and i could enter my account-details (from fb) and password but when i then hit “enter” it got me to a new errormessage “URL can’t be loaded… domain isn’t known in domain of apps”… :thinking:

Might be worth raising an issue tbh, it’s relatively new and not unlikely to be bug free.

i have already done it… with noone really taking care about it. so this one here is my backup-try :wink:

plus i even got further again. it could be that addin doesn’t like the formatting of username… when you log-in to fb. i mean i have setup an unique username on fb and am able to login using it. but it doesn’t consist of any “@domain.tld”-ending. it’s just a name.
so i tried a 2nd fb-account and logged in using an emailaddress… and there you are. it works. but i need to find out about my registered emailaddress for 1. account and try it with that one then. or otherwise i could be that i have all apps blocked from fb with my first account. we’ll see.

i’m getting there

1 Like

to re-enable all apps with fb did the trick. now it works, problem solved.

thanks @JasonBayton - without your contribution it wouldn’t have been possible to solve it.

(N.B. Im going to re-disable it as i don’t want to use fb-apps at all)

1 Like