Can't send test emails, why?

I was configuring my email server and when I press “Send Mail” this message pops up:
There was a problem sending the email. Please check your settings. (Error: The email could not be sent. Please check your email server logs.)
Can anybody help?

Through which email provider are you trying to send the mails? And can you please post your exact config here (you can anonymize the email address). Without this info no one will be able to help you.

I wanted to redo the SMTP config and now everytime I change anything it asks for the Authentication password, but I don’t have anything on the Authentication

Ok, it’s not asking anymore.
So I was using my gmail account to send testing emails

Does that mean it is working now?

Still not sending the email :confused:

What I am looking for is to configure the email that NextCloud sends when a user registers

But first I wanted to test that

In order to use third party clients with Gmail, which Nextcloud technically is, you have to turn on “Less secure apps” and create an “App Password”. See here:

After you did that, the following settings should work in Nextcloud:

Send mode: SMTP | Encryption: SSL/TLS
From address:
Server address: : 465
Authentication Method: Login
Credentials: | the app password provided by Google

Try changing the port to 465.

…if that doesn’t work, you could try port 587 with Encryption type: “None” (which should use STARTTLS, if available on the server side)

Did you also try port 587 with encryption “Plain”? Otherwise I’m not sure why it doesn’t work…

Is that still a Gmail / Google Workspace Account, your trying to connect to or some other mail provider / mail server? Is all of other information like the email address / login name, password, server name etc. correct? Is there a more detailed error message in the Nextcloud log?

The logs say this:

E323587308: uid=33 from=
Jun 12 12:00:01 nextcloud postfix/cleanup[2330]: E323587308: message-id=20230612120001.E323587308@nextcloud
Jun 12 12:00:01 nextcloud postfix/qmgr[1273]: E323587308: from=www-data@nextcloud, size=701, nrcpt=1 (queue active)
Jun 12 12:00:01 nextcloud postfix/local[2332]: E323587308: to=www-data@nextcloud, orig_to=, relay=local, delay=0.02, delays=0.02/0/0/0, dsn=2.0.0, status=sent (delivered to mailbox)
Jun 12 12:00:01 nextcloud postfix/qmgr[1273]: E323587308: removed

Mine just has SSL/TSL and None

Yes you are right, the setting woiuld be “None” not “Plain”. But did you try that with Port 587? It should then use STARTTLS if available on the mail server…

If none of these combinations work, either one of the other settings is wrong (server name, username, password etc…), or rather unlikely, the mail server is using an uncommon port. You can typically find these details on the mail provider’s website.

Or maybe the server doesn’t allow SMTP connections from third party clients at all. Like I said, with Gmail for example, you have to explicitly allow access for third party clients via app password.

Other than that, nothing else comes to mind, but to be honest, I doubt that this is a Nextcloud issue…

1 Like

so i have had nextcloud working before. did new install to fix some bugs (still didn’t). and now i cannot get my smtp settings to work and they are exactly setup like your list. I too am getting the " A problem occurred while sending the email. Please revise your settings. (Error: Email could not be sent. Check your mail server log)" error.

I tried the encryption change and port change and still same error. any ideas?

(after hours of tinkering) it seems to be a google issue… used my hotmail account and it works fine. not nearly as professional but i guess it’s a solution.

1 Like