can't reach nextcloud GUI over internet

Hi All, i’m having issues reaching my nextcloud install(running on freenas) over the internet. i’ve opend up port 80 on my router directing to the internal ip of my nextcloud installation but when i try to acces it over the internet i get a freenas webpage with the message: connecting to NAS… make sure the NAS system is…etc.

I’ve configured the Freenas Gui to be on port 81 and opend this up in my router aswell, i can acces the freenas GUI just fine, why isn’t this working for the nextcloud GUI?

it’s my first time trying to setup a server(of any kind) so i have very limited knowledge. i wanna find out if i nextcoud will work for me so for now i’m not worrying to much about security, just trying to get a connection going.

could anyone help me out and/or direct me to a good and very basic guide?


Can you post a screenshot of your port forwarding settings on the router?
Accessing Nextcloud from within your local network via http://<local IP>:80 is working fine? Or are you adding something to the URL like: http://<local IP>:80/nextcloud ?
And you access FreeNAS within your local network via: http://<local IP>:81 ?

On an unrelated note, you’ll want to avoid using unencrypted HTTP with your data.


It seems like you have either have not forwarded to the jail IP, or that the networking part of your FreeNAS jail is incorrect. I have no real expertise in the area, but I have not been able to get jails to work correctly if you don’t create them with VNET enabled, something about the jail sharing network stack with the host system. Jails created with VNET enabled get an independent network stack. I would ask the FreeNAS forums about your issue, since it is probably a OS issue, not a Nextcloud issue.

Secondly, as somebody has already touched upon. Please do not allow unencrypted traffic to basically any service accessed over the internet. You should open port 443 and direct it to your Nextcloud server, and create a redirect rule that redirect all traffic on port 80 to port 443. Alternatively, set up a proxy server on your NAS that does the same thing. Which one depends on if you want to have more stuff running on the NAS in the future

Thirdly, I am pretty certain exposing the FreeNAS GUI to the internet at large is very bad security practice. The older FreeNAS versions certainly where not hardened enough to be publicly accessible. You should use VPN if you need remote access to the GUI, or live with only SSH access (with public keys set up) as you learn how to use it. SSH access is more powerful anyway

thanks for the reply’s so far, i’ll be working on this again tonight so more later.

regarding security, i’m not leaving ports open all the time, just when trying to get things running. i know the dangers etc but i figure that if i can’t get a basic connection going adding security now will only complicate things for me more.

i’ve tried using port 443 but i don’t get any connection at all through that.

as an unexperienced user, baby steps just feels like the best way to go at this.

Any progress in this? i m having the same problem.

I found this guide very helpful when migrating to php-fpm.

I still think it sounds like some issue that is separate from Nextcloud, and instead networking/OS issue. Can you get a php test page to load correctly? Both from within LAN and externally?

This is going to be a firewall configuration issue.