Can't reach my Nextcloud Docker anymore (no errors, everything runs)

Nextcloud version: 25.0.2
Operating system and version: unRAID 6.11.1, nextcloud Linuxserver Docker
nginx version: 2.9.18
PHP version: no idea :frowning:

The issue you are facing:
I can’t reach my Nextcloud anymore. It stopped working from one day to another, can’t recall I changed anything (like updating a Docker). Can’t tell when it happened exactly, I just noticed from my PC having a grey icon instead of the green.
Trying to reach it gives a “ERR_CONNECTION_TIMED_OUT” in Chrome.

I run the linuxserver Nextcloud Docker on my unRAID, mariaDB as database and nginx as DynDNS Service. The DynDNS is from my personal domain. I setup a test DynDNS to check nginx functionality, which works fine.
Ports in my router are still set and work fine :confused:

The Docker runs and docker-logs show no errors, same for mariaDB, nginx says it’s “online”.

I’m not good with anything Linux so I have a hardtime finding all the files and info needed, hopefully I can make due :frowning: I have no idea what to do

Is this the first time you’ve seen this error? (Y/N): Y

The output of your Nextcloud log in Admin > Logging:

as I can't access nextcloud, I can't get the log

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'datadirectory' => '/data',
  'instanceid' => 'ocme13n05qve',
  'passwordsalt' => 'redacted',
  'secret' => 'redacted',
  'trusted_domains' => 
  array (
    0 => '',   # unraid ip within my network
    1 => 'redacted',   #my dyndns
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'overwritehost' => 'redacted',   #my dnydns
  'overwriteprotocol' => 'https',
  'dbname' => 'redacted',
  'dbhost' => '',   #mariaDB port
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'redacted',
  'dbpassword' => 'redacted',
  'installed' => true,
  'default_phone_region' => 'DE',
  'mail_domain' => 'redacted',
  'mail_from_address' => 'redacted',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_smtpsecure' => 'tls',
  'mail_smtphost' => 'redacted',
  'mail_smtpport' => '25',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtpname' => 'redacted',
  'mail_smtppassword' => 'redacted',
  'maintenance' => false,
  'loglevel' => 2,
  'theme' => '',
  '' => 'stable',

The output of your Apache/nginx/system log in /var/log/____:

I'm not sure where to find it; ...\nextcloud\log\nginx has access and error logs (the latter being empty)

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

I can't find that file either; Documentation says it's in the "data" folder, I don't have that folder anywhere :( tried to use the filesearch in my appdata (where Docker data sits), but no dice

As an addendum, up until today it seems that the webdav backups from my phone still went through. Starting today, I get the constant network errors as notifications. Seemingly, nothing with my dockers changed in any way.

Ok now it gets weird.

Today, I received a mail from my Nextcloud that there’s an update for some Nextxcloud application.

So, it’s still running. I just can’t reach it?

In case anyone finds this through google, I found the culprit.

Somehow, the DDNS got messed up. My test-domain went fine, but somehow the old one was broken, same settings though. I deleted it and made a new one with all the same setup, now it works just fine.

Could easily be this happened the last time as well. Will give my webhoster a call how I can prevent this.