Cant move nc data to external harddisk


Have a problem NCP Version is 1.4.11, when i want to move the nc data dir to the external Harddisk it every time the error “Refusing to move to the SD card. Abort”, the message alwasy the same, it is a fresh format ext4 disk, i dont know why its not working. With the database and other it works well.

thank you

Your drive needs to be mounted (automount) and the path needs to be inside the hard drive mount

1 Like


I know that the drive must be automount, i have it automount with the wizard. Before i installed nextcloudpi (with Berryboot), i have wipe the drive complete all sectors fill with 0, then format it with ext4, the strange is i run the wizard, and then i have two mount Point in de /media folder “USBdrive” and USBdrive1". I dont understand why because i wipe the disk and this take some hours. Have anyone a solution i dont want to wipe it again. The Error Message is “Refusing to move to the SD card. Abort”.

thank you for helping


Nobody a solution, all other can i write in Backups, database, and NCP Export, the only Problem is des ncdata, i have created a new folder for ncdata but the problem is the same "Refusing to move to the SD card. Abort”. can anyone give me a hint?

thank you


I have played a while, and now i have the data in my directory,
only error that i have is when i active Fail2ban it write “directory /var/www/nextcloud/data not found”
i have in some config change the logfile directory of fail2ban, but without to get it fixed, how is it to config.

And a other question on the system info it writes datadir the right folder and data on sd: “yes” is this right or must?
And must i change something is the sql.

i’m not a beginner but don’t have full knowledge with linux, so i always have to sacrifice a lot of time to fix something.

Thank you much for your Help

Problem solved

Can be Closed

I have similar problem. I have Odroid-XU4Q with latest Armbian and thru armbian-config I installed NCP. Beforehand I made btrfs filesystem in raid1 on two USB storages. Btrfs automounts on /mnt/test-btrfs in fstab. lsblk shows that the filesystem is mounted and I can create files and dirs in it. Btrfs shows everyting normal, I can balance the filesystem… In NCP I have enabled automount and in nc-datadir it says: [ nc-datadir ] Refusing to move to the SD card. Abort

Any ideas?

it only checks that the destination fs is different from /. Is that the case?

I’m running Armbian and NCP install from USB thumb drive in / btrfs fs. And than I have two aditional USB thumb drives(on separate btrfs fs) mounted on /mnt/test-btrfs in raid1 config. I’ll post more config setup when I get home.

OK, so I did a clean install of Armbian today, moved rootfs to USB in btrfs fs, made update && upgrade, then I made another btrfs fs on a USB key, added second one and balanced it. Next I installed NCP thru armbian-config, tried to go thru wizard and it didn’t want to mount second btrfs fs. Automount on/off, reboot odroid, nothing helps :confused:

more info:

I see what your problem is, like I said the fs in / has the same device number as the fs in /media,

What do you get in stat -fc%d / and stat -fc%d /media/whatever?

I get for both value 0 .

I tried with only one freshly formated in btrfs fs USB key storage and I get the same problem(device is mounted, but I can’t place on it datadir) and same 0 value for stat -fc%d command :confused: .

ok, please update to the latest version (ncp-update) and try again.

1 Like

Thank you nacho it works! And thank you for being such a great developer to ease the process of installing and using NextCloud :slight_smile: . Keep the good work :+1:

If I may bother you for few more question that I have.

  • What are the default setting that automount uses for btrfs fs? Compression=lzo/zstd, autodefrag,…
  • And would it be enough to mount the device/fs thru fstab instead of using automount?

Thank you again.

1 Like

the settings you can see with the mount command.

Ofc you can mount manually with fstab. Automount is meant for non technical users

1 Like