Can't map hard drive, Can't log in Pi terminal

Nextcloud will not mount usb storage

Nextcloud V.1.16.6

is set up on a RasberyPi 3 using https://ownyourbits.com/2017/02/13/nextcloud-ready-raspberry-pi-image/

Rabian is NOT installed. The only thing in the SD card are the file for Nextcloud.

this means when power is connected to the Pi it loads only a terminal, and runs Nextcloud

Screen 1:

I have the Pi 3 connected with ethernet cable and connected to a monitor. There’s a USB Switch that lets me swap keyboard form computer, to Pi On Boot of the Pi, I see a login screen. I’m aware…

The default username of PI is

Username:pi

Password: rasbian

Login incorrectnextcloudpi Login: (waiting for another try) —

I’m aware…

Default username and password of Nextcloud is

Username: npc

Password: ownyourbits

This doesn’t work.

So. Giving up on Screen 1 for a moment since I can’t do squat but try to log in…

Screen 2:

Screen 2 is the computer in the same network. I’m able to go to the IP of the pi (found using Angry Ip Scanner) and view the activation page. I’m able to run the at ip/wizard and set everything up. I’m able to log into Nextcloud and see the defualt files.

HOWEVER. at this point it’s using the SD card. I have a 9T hard drive I’d like to use that is already filed with of .PDFs MP3, .TXT files. Simple stuff.

During the Wizard of Nextcloud setup I was able to set

‘‘Automount USB’’ I ‘‘plugged it in’’ pressed continue. The second screen showed …something going on…

I continued.

No external options. After some googling discovered I needed to

User icon > Settings > Apps > enable External storage support Now when logging out and logging back in under settings there’s a new External Storage option

it wants me to map the drive and I don’t know what to type.

If I click the Pi icon at the top it kicks me to a back-end page with options. I can see nc-automount with a Checkmark

Automount USB drives by plugging them in

Plugged in USB drives will be automounted under /media on boot or at the moment of insertion. Format your drive as ext4/btrfs in order to move NC datafolder or database. VFAT or NTFS is not recommended for this task, as it does not suport permissions WARNING If you want add a second drive later, make sure you have added a LABEL to the first and all other drives to be mounted when formating, as they will then be mounted at /media/LABEL instead of /media/USBdrive IMPORTANT: halt or umount the drive before removing

There’s a checkmark in active. It also shows a check mark when you select the options on the… sidebar thing. it’s active.

That sounds great! Except it’s not working.

If I was able to log into the First screen I could run

sudo blkid

to show what’s connected. But I can’t log in screen one. It’s asking for a username I don’t know and a password I can’t seem to find after HOURS of searching.

Default password? ownyourbits rasbery i don’t know… halp.

Since I can’t log in to find the drives, and it;s not AUTO DETECTING THE DRIVE like it said it will…

I’m stuck.

PLEASE HALP

[/details]

Nextcloud V.1.16.6

Operating system and version _ Nextcloud image

Apache or nginx version (eg, Apache 2.4.25):

PHP version (eg, 7.1):

The issue you are facing:

I’m unable to mount a hard drive. I have a external hard drive I’m trying to use with Nextcloud, and when going to External Storages/ It wants the location of the drive.

I have the Pi connected to another monitor so I can type on it.

I have a login screen in terminal, (on the PI)

and can open Nextcloud from the other screen with a browser.

But I can’t log in on the PI!

username: I’ve tried ncp

Password: ownyourbits

I’ve tried

Username: ncp

Password Ownyourbits.

I’ve tried

Username: ncp

Password ownyourbits

If I could log in, I could run ls disk to map whats connected, then go back to the other screen and put that location in, letting Nextcloud map my drive.

But I’m stuck

Screen one: trying to log into the Pi.

There’s no Rasbian on this card. it’s just the live image of Nextcloud.

Meanwhile on the Nextcloud GUI I can log into nexcloud interface, but can’t see files. I can try to add a external hard drive but it wants me to type the location. I don’t know the location so I’m going to the other monitor and trying to log in.

I can’t log in, so finally I’m asking for some assistance.

Is this the first time you’ve seen this error? (Y/N):

The output of your Nextcloud log in Admin > Logging:


Warning Login failed: 'ncp' (Remote IP: 'REDACTED')

2019-09-16T22:43:40-0700

Warning Login failed: 'ncp' (Remote IP: 'REDACTED')

2019-09-16T22:05:25-0700

Error Doctrine\DBAL\Exception\DriverException: An exception occurred while executing 'SELECT `id`, `numeric_id`, `available`, `last_checked` FROM `oc_storages` WHERE `id` IN (?)' with params ["local::\/var\/www\/nextcloud\/data\/"]: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


PASTE HERE

The output of your Apache/nginx/system log in /var/log/____:


Since I'm using a live image I'm not able to show the outout of var log. At least not without signing in first

Is no longer in use, check documentation FAQ

What are pre-set users/passwords on NextCloudPi?

There are no pre-set passwords, the following are randomly generated upon first access during activation.

For terminal pi/raspberry (root/1234 on Armbian)
For SSH: generated on demand on ncp-web SSH section.
For nextcloudpi.local:4443 ncp/<random> (stored and reset in nc-passwd)
For nextcloudpi.local ncp/<random> (stored and reset in nc-admin)
For Database user is ncadmin/<random in /root/.my.cnf>
1 Like

Figured half of this out.
I was misspelling raspberry
now trying to get the drive to mount

Thanks for the info about ownyourbits no longer being in use!