Can't manage apps

Nextcloud version: 11.0.1
Operating system and version: Debian Jessie 8.7
Apache or nginx version: Nginx 1.6.2-5+deb8u4
PHP version : 5.6.30+dfsg-0+deb8u1
Is this the first time you’ve seen this error and can you replicate it?: Yes I can replicate it, and it’s a new installation (I also had the problem on an older installation, I suspected to be slightly weird), “new” as in “I wiped /var/www/nextcloud and made a new databaseuser and a new database, so the only reuse is in the nginx setup”.

The issue you are facing:

When I go to “Apps” in the menu at the top left, all that happens is that turning circles indicating that something is loading is shown for a while. Nothing ever appears.

I’ve searched for the issue and found stuff about broken internet connections, which I believe not to be the case here (no errors appear in Admin/Server settings (I fixed that while on my old installation), I also found the suggestion to delete data/files_external/rootcerts.crt. I didn’t help - the file was recreated, but I guess that’s expected?

The output of your Nextcloud log in Admin > Logging:
3 occurences of:
Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set ‘always_populate_raw_post_data’ to ‘-1’ in php.ini and use the php://input stream instead. at Unknown#0
before that (22 minutes ago, about a minute after a database error that occured while I was trying to do the new installation, so this must be around the setup actually worked, and before I tried visiting “Apps”, but for completeness:
InvalidArgumentException: The given object name is invalid

/var/www/nextcloud/apps/activity/lib/FilesHooks.php - line 892: OC\Activity\Event->setObject('files', 2, false)
/var/www/nextcloud/apps/activity/lib/FilesHooks.php - line 184: OCA\Activity\FilesHooks->addNotificationsForUser('grove', 'created_self', Array, 2, false, true, true, 0, 'file_created')
/var/www/nextcloud/apps/activity/lib/FilesHooks.php - line 111: OCA\Activity\FilesHooks->addNotificationsForFileAction('/', 'file_created', 'created_self', 'created_by')
/var/www/nextcloud/apps/activity/lib/FilesHooksStatic.php - line 45: OCA\Activity\FilesHooks->fileCreate('/')
[internal function] OCA\Activity\FilesHooksStatic fileCreate(Array)
/var/www/nextcloud/lib/private/legacy/hook.php - line 106: call_user_func(Array, Array)
/var/www/nextcloud/lib/private/Files/View.php - line 1237: OC_Hook emit('OC_Filesystem', 'post_create', Array)
/var/www/nextcloud/lib/private/Files/View.php - line 1163: OC\Files\View->runHooks(Array, '/grove/files', true)
/var/www/nextcloud/lib/private/Files/View.php - line 266: OC\Files\View->basicOperation('mkdir', '/grove/files', Array)
/var/www/nextcloud/lib/private/Files/Node/Folder.php - line 149: OC\Files\View->mkdir('/grove/files')
/var/www/nextcloud/lib/private/Files/Node/Root.php - line 380: OC\Files\Node\Folder->newFolder('/grove/files')
[internal function] OC\Files\Node\Root->getUserFolder('grove')
/var/www/nextcloud/lib/private/Files/Node/LazyRoot.php - line 65: call_user_func_array(Array, Array)
/var/www/nextcloud/lib/private/Files/Node/LazyRoot.php - line 282: OC\Files\Node\LazyRoot->__call('getUserFolder', Array)
/var/www/nextcloud/lib/private/Server.php - line 947: OC\Files\Node\LazyRoot->getUserFolder('grove')
/var/www/nextcloud/lib/private/User/Session.php - line 411: OC\Server->getUserFolder('grove')
/var/www/nextcloud/lib/private/User/Session.php - line 479: OC\User\Session->prepareUserLogin(true)
/var/www/nextcloud/lib/private/User/Session.php - line 299: OC\User\Session->loginWithPassword(*** sensitive parameters replaced ***)
/var/www/nextcloud/lib/private/Setup.php - line 393: OC\User\Session->login(*** sensitive parameters replaced ***)
/var/www/nextcloud/core/Controller/SetupController.php - line 65: OC\Setup->install(Array)
/var/www/nextcloud/lib/base.php - line 957: OC\Core\Controller\SetupController->run(Array)
/var/www/nextcloud/index.php - line 40: OC handleRequest()

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'ochokcwmgflh',
  'passwordsalt' => '**Hidden**',
  'secret' => '**Hidden**',
  'trusted_domains' => 
  array (
    0 => '',
  'datadirectory' => '/var/www/nextcloud/data',
  'overwrite.cli.url' => '',
  'dbtype' => 'pgsql',
  'version' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'nextcloud',
  'dbpassword' => '**Hidden**',
  'logtimezone' => 'UTC',
  'installed' => true,

The output of your Apache/nginx/system log in /var/log/____:

2017/02/11 12:30:20 [error] 22916#0: *281 upstream timed out (110: Connection timed out) while reading response header from upstream, client:, server:, request: "GET /index.php/settings/apps/list?category=enabled HTTP/1.1", upstream: "fastcgi://unix:/run/php5-fpm.sock", host: ""
2017/02/11 12:32:42 [error] 22916#0: *320 access forbidden by rule, client:, server:, request: "GET /data/.ocdata?t=1486812762495 HTTP/1.1", host: ""
2017/02/11 12:33:00 [error] 22916#0: *322 access forbidden by rule, client:, server:, request: "GET /data/.ocdata?t=1486812780070 HTTP/1.1", host: ""

As nobody has offered any help, I debugged this myself, and strace’ing some php processes (nextcloud is the only php code on the server, so anything I saw had to be related to nextcloud), I found that it resolved, and as that resolves to a different ip than, that I opened for traffic to when I investigated the error message about “no internet connection” in Admin/Server Settings.

As soon as I added firewall rules allowing http and https to the ip for, it started working. The documentation really should offer a list of what connections might be made.

Is there any other functions that might make connections to other ip’s?

@LukasReschke is there a port/network requirements doc on the docs server?