Can't login when Redis set to PHP session

centos
redis
php73
nc15

#1

I heard the voice of high evaluation from the person who is running NC using PHP 7.3. So I also tried PHP 7.3, but I can not run NC15. The login screen is displayed. However, even if I enter correct account information, I will not proceed.
I also use Redis for PHP session Path. I gave up using Redis and switching to APCu NC15 worked on PHP 7.3. I tried clearing Redis’s cache and restarting the server, but it did not change at all.

Is this due to Redis? Or NC15?


Nextcloud 15.0.0 / PHP 7.3 / CentOS 7.5 / Redis 5.0.3 / Nginx 1.14.1


#2

Hi,

I’m not sure about the root cause of your issue, however, I successfully run NC15 with PHP7.3 and redis 5.0.3.


#3

This is what happens to me with 7.3


#4

I have set up as below so far.

  • session.save_handler = redis
  • session.save_path = “tcp://127.0.0.1:6379?auth=???”

I upgraded to PHP 7.3.2 and PHP 7.2.16, but the situation does not change.
I will be able to use NC if I return as follows. This is PHP 7.3.0 or later.

  • session.save_handler = files
  • session.save_path = “/var/lib/php/session”

#5

I have updated PHP 7.3.2 to 7.3.3. NC has also been updated to 15.0.5. But nothing changed.
This is caused by updating from PHP 7.3.1 to 7.3.2 (or 7.2.15 to 7.2.16). Are there any other settings I should change?

session.save_handler = redis
session.save_path = “tcp://127.0.0.1:6379?auth=???”

With the above settings.
It’s strange. I once changed PHP to 7.1.27. And change to PHP 7.2.16. Then I was able to specify Redis for PHP Session and logged in to NC. But I can not login with PHP 7.3.3.


#6

Most likely you’ve not installed the required php 7.3 module for Redis.


#7

I solved the problem after upgrading Redis 4.2.0 to 4.3.0 with pecl.