Can't login via web - tried all found solutions but none work :(

Nextcloud version (eg, 10.0.2): 12.0.2
Operating system and version (eg, Ubuntu 16.04): CentOS 7
Apache or nginx version (eg, Apache 2.4.25): Nginx 1.12.1
PHP version (eg, 5.6): 7.1.8
Is this the first time you’ve seen this error?: Yes

Can you reliably replicate it? (If so, please outline steps):

The issue you are facing:

NextCloud instance has been working for several months and I rarely used the web interface but I’ve come to make some changes and can’t log on. No errors are output to the nextcloud.log and I can’t spot anything in the browser tools other than the message “DevTools failed to parse SourceMap: https://cloud.familycliff.co.uk/core/vendor/dist/purify.min.js.map

I have:

  • Deleted the instanceid from config.php
  • Upgraded to the latest version (via command line)
  • Tried multiple browsers on multiple PC’s, including incognito mode
  • Have run occ integrity:check-core

I can see the request hit nginx (in access.log) but nothing is showing in error.log

I am completely stumped now and about to give up … if someone could help I’d be really grateful!

[edit: Forgot to say, I also disabled the files-sharing app as some said that was a work around but no joy]

Steve.

I’m still completely stuck on this and about to give up on Nextcloud … :frowning:

Hey there. I’m not one of the devs so I can only offer what normal user thoughts I have on this. I have to say I think deleting the instance ID was probably not the best thing to do but hey ho :wink:

Is the user you’re trying to log in with an eternally authenticated one, such as an LDAP user?

Did you have an email address associated with it in Nextcloud?

What happens when you try to login?

Your hard disk is full?
df -h

If not, any output of other logfiles (webserver, system, … ), you can scan through /var/log/* if an error pops up somewhere.

Thanks for the comments :slight_smile:

I hope I didn’t make things worse by deleting the instance ID … oops! I was running out of ideas - lol.
I’ve not set up LDAP on this instance so all users are local. All users also have an email address (and nothing is sent through). At the web page you enter the user/password, click the login button and then the screen simply goes back to the login screen again …

I face the same since ever on opera browser console, so this should be not connected with the issue you face. It is also shown as warning, not as error.

About the instanceId: If you still have the old one, put it back in place or keep it. It is at least connected to the appdata_<…> folder Content and I remember huge issues after removing it once.

Yeah answers to the others questions above could help :slight_smile:.

I was really hoping that I could find something in a log file somewhere but I haven’t spotted anything so far :frowning:
Nginx, php-fpm logs for instance show nothing other than I can see the site being accessed.

Just to confirm, the client software is working fine.

Plenty of space on the drives too :frowning:

Filesystem                   Size  Used Avail Use% Mounted on
/dev/mapper/vg_root-lv_root  113G   12G  102G  11% /
devtmpfs                     1.9G     0  1.9G   0% /dev
tmpfs                        1.9G     0  1.9G   0% /dev/shm
tmpfs                        1.9G  8.5M  1.9G   1% /run
tmpfs                        1.9G     0  1.9G   0% /sys/fs/cgroup
/dev/sda1                    477M  243M  206M  55% /boot
/dev/mapper/vg_root-lv_var   4.0G  1.7G  2.4G  42% /var
/dev/mapper/vg_root-lv_tmp   2.0G   34M  2.0G   2% /tmp
tmpfs                        380M     0  380M   0% /run/user/1000
tmpfs                        380M     0  380M   0% /run/user/0

I do have solr installed - not sure if that could be anything but …

@Michaelng - yeah, beginning to think removing the instance ID as suggested by some other posts wasn’t the greatest of ideas I’ve had … :slight_smile:

Just for info - I’ve replaced the instance ID back with the original one now but still no difference.

If you can cd into the data folder of where your Nextcloud is installed, there should be logs in there. Would be worth trying to log in and then get the most up to date output from that log for us to have a look at.

As an example, my log file would be in /var/www/html/data/nextcloud.log

Well, this is interesting - nothing is being written to the Nextcloud.log since I last ran the core integrity check (back on the 22nd August). I’ve deleted the log file and reboot the server and it has been recreated so will watch what happens.
I presume I should have at least some information being written it???

A permission issue? SELInux?
Can you also try a different browser or a different computer? Some security plugins or add blocker could perhaps prevent the loading of required resources.

If you tried a couple of logins, there could be the bruteforce protection (though it should show up in the logs), you can manually turn it off by putting this line in your config.php
'auth.bruteforce.protection.enabled' => false,

I did wonder on SELinux but checked and it’s set to permissive, which I think is ok?

I’ve tried adding the bruteforce option but still no good. And also absolutely no entries in Nextcloud log file … I really think it’s seriously messed up :frowning:

Ok - thanks for everyone’s thoughts on this - I appreciate the input but I’ve spent days trying to sort this out and think I’m going to have to give up on it. It’s a shame as I really like NextCloud but if it can get in this state then I can’t rely on it going forward :frowning:

well… .since you tweaked your instance like crazy… why not giving it a final chance by doing a complete new installation from scratch? and then see how far you come?

Yeah, I understand what you are saying but I only tweaked after it broke and nothing seems to have fixed it. Plus I’m already going to annoy quite a lot of people changing things around to another product … really don’t want this to happen again in the future and annoy them all over again :slight_smile:

The only thing I could possibly try I guess is linking this in with a Docker project running currently - I could attempt to spin up NextCloud in a Docker container and then try and import database/files …

either that… or just wait for the next update. maybe it’s gonna fix your problems anyway

Before you change everything, make a backup first.

Under “The issue you are facing” I would expect a precise description about what you are doing, what is expected to happen, and what happens.
What do you mean by “can’t log on”?
In my installation I am facing a disabled login button: (SOLVED) Nextcloud 12: Login button not working

If I try to log in admin with an arbitrary password on https://cloud.familycliff.co.uk, I just get back to the login screen, without any error message.
Is that the problem you are facing?

Forgot to ask: Did you look in data/nextcloud.log?

1 Like

Odds are you set the ownership of your php-fpm directories during install - but you should double check that they are still correct. I use ISPconfig to manage virtual domains and email and when I upgraded it, it changed the ownership to apache:apache, where I always mean keep them at nginx:apache

Check that the proper webserver has ownership of your session directory especially…

1 Like