Can't login via https://nextcloudpi.local:4443

ich hab zunächst 3 fragen:

  • welche version von ncp fährst du aktuell?
  • ging das einloggen ins webgui zuvor?
  • hast du etwas geändert (außer ggf ein update gemacht)?

Hi JimmyKater!

welche version von ncp fährst du aktuell?
NextCloudPi 18.0.3

ging das einloggen ins webgui zuvor?
Ja, das ging mal.

hast du etwas geändert (außer ggf ein update gemacht)?
Nicht wissentlich.

Aber ich sehe gerade:
Es gibt einige Warnungen bei Deiner Systemkonfiguration.
Dieser Installation fehlen einige empfohlene PHP-Module. Für bessere Leistung und bessere Kompatibilität wird dringend empfohlen, diese zu installieren.
imagick

das dürfte damit nichts zu tun haben… oweit ich weiß hat das nur mit der theming-app in nextcloud zu tun.

diese version existiert noch nicht…
NextCloudPi (kurz: ncp) müsste irgendwas mit 1.2x.x sein… dein NextcloudServer hat hingegen die versionsnummer 18.0.3. (die derzeit aktuelle stable)
um die versionsnummer von NextCloudPi rauszufinden, müsstest du dich per ssh in deinen pi einloggen - da erscheint sie gleich zu beginn…

Sieht nach einem Netzwerkfehler aus. Probiere mal Edge oder Firefox.

Ich habe keinen Pi. Aber funktioniert

sudo ncp-report

Sorry… NextCloudPi v1.24.0

No ncp-report in bin? Use correct path or change to ncp - bin - path.

sudo ncp-report funktioniert. Mit Firefox und Edge geht es auch nicht. :frowning:

vielleicht ist das der gleiche fehler, der auch bei mir auftaucht… —>

Ja, das kann’s sein.

dann schlage ich vor, wir warten ab, was die englischsprechenden devs dazu sagen. oder? vielleicht gibts ja hier auch helfende vorschläge

So machen wir das. Hab vielen Dank trotzdem!! :slight_smile:

1 Like

Hallo allerseits, ich bin neu hier, lese hier aber mit großem Interesse mit…ich habe das gleiche Problem, hoffe es findet sich eine Lösung…
Ich bin ein einziges Mal in das webgui gekommen, und zwar direkt nach der Erstinstallation. Da habe ich dann direkt einige Einstellungen bzgl. trusted domains und samba vorgenommen. Dann ausgeloggt. Danach - kein Einloggen mehr möglich…

Es öffnet sich immer eine Eingabaufforderung für Usernamen und Passwort (“ncp-web login”), aber es funktioniert nichts. Weder der User “ncp”, noch “pi” - und auch nicht das alte Default-Passwort sowie das dann von mir geänderte Passwort. Irgendwelche Sonderzeichen im Passwort nutze ich auch nicht - nur Buchstaben und Zahlen. Ich bin absolut ratlos.

bei mir hat sich das problem übrigens von ganz allein gelöst. ich bin vollkommen ratlos. - dies nur der vollständigkeit halber

dir kann geholfen werden… du solltest auf deine instanz ssh’en und dort sudo nc-config aufrufen. von dort aus kannst du einen webgui user (neu) anlegen… ebenso wie dessen password.

@Flo_Pi

hast du denn - sorry, dass ich erst jetzt drauf komme - auch schon mal versucht, von innerhalb deines lans mit https://lokale.ip.von.nc:4443 drauf zuzugreifen?

@JimmyKater

Danke, ich versuche es heute Abend mal…hatte mich dort schon eingeloggt und ein Passwort hinterlegt, aber den Usernamen „ncp“ unverändert gelassen…vielleicht liegt es daran?

Ja, zeigt leider das selbe Ergebnis, auch mit verschiedenen Browsern. :frowning:

hast du über ssh und nc-config probiert, ob das webgui angeschaltet ist? zur not mal ab und wieder anschalten und apache2 neu starten (systemctl restart apache2, ggf mit sudo)?

am usernamen sollen es nicht liegen…

wichtig ist allerdings der umstand, dass es zwei user gibt, die du konfigurieren kannst… den einen für die nextcloudinstanz selbst (ich glaube, der heißt nc-admin oder so) und der zweite für die webgui. du möchtest den für die webgui editieren. --> ncp-passwort

also ich bin via ncp-config rein und habe unter “nc-passwd” ein Passwort eingegeben - Usernamen gibt es da gar keinen?! .

Unter nc-webui habe ich dann einmal “no” eingegeben, dann wieder “yes”, dann raus und apache neu gestartet.

Es bleibt dabei, es kommt immer der Anmeldebildschirm…egal was ich eingebe.

Was ich nicht verstanden habe: Wo kann ich für das webgui in der ncp-config einen Usernamen anlegen? Ich habe da unter nc-passwd nur das Passwort anlegen können, aber von einem User sehe ich da nirgendwo etwas…nur unter nc-admin, aber das ist ja was anderes.