Can't login to my cloud web based

Hii… there,

I have a problem login my cloud on web based, yesterday it work fine, but today I can’t enter the cloud web based because the “Log In” button is unclickable like image below.

But I can login to my cloud with apps on android and apps on windows, but not on web based. Currently I run NC 11.0.2

Thank You

Have you tried using private mode, clean cokies, or another browser?

I did, I try to clean cookies several times and using other browser, but it can’t help.

Do you have shell acess?
Run integrity tests with occ

It seems like some file is missing, .htaccess or .user.ini
Can’t tell, try that.

I run my cloud on shared hosting, is it possible to do shell acess or tests with occ? I don’t understand,
is there a tutorial?

occ is a shell tool to do admin stuff,
You need shell access to use it, some hosting providers give shell access, most don’t.

Does your hosting provider gives you shell access?

Check here:

Do you have ftp access?
To look for files like user.ini and .htaccess

I have exactly the same issue as irfan: fresh install by script (softaculous ) on a hosted environment running PHP 7.1 with no SSH access. I can edit files in webroot however.

Any help would be greatly appreciated.






SetEnvIfNoCase ^Authorization$ "(.+)" XAUTHORIZATION=$1 RequestHeader set XAuthorization %{XAUTHORIZATION}e env=XAUTHORIZATION SetEnvIfNoCase Authorization "(.+)" HTTP_AUTHORIZATION=$1 # Add security and privacy related headers Header set X-Content-Type-Options "nosniff" Header set X-XSS-Protection "1; mode=block" Header set X-Robots-Tag "none" Header set X-Frame-Options "SAMEORIGIN" Header set X-Download-Options "noopen" Header set X-Permitted-Cross-Domain-Policies "none" SetEnv modHeadersAvailable true

Add cache control for static resources

<FilesMatch “.(css|js|svg|gif)$”>
Header set Cache-Control “max-age=15778463”

Let browsers cache WOFF files for a week

<FilesMatch “.woff$”>
Header set Cache-Control "max-age=604800"

php_value upload_max_filesize 511M
php_value post_max_size 511M
php_value memory_limit 512M
php_value mbstring.func_overload 0
php_value always_populate_raw_post_data -1
php_value default_charset 'UTF-8’
php_value output_buffering 0

SetEnv htaccessWorking true

php_value upload_max_filesize 511M
php_value post_max_size 511M
php_value memory_limit 512M
php_value mbstring.func_overload 0
php_value default_charset 'UTF-8’
php_value output_buffering 0

SetEnv htaccessWorking true

RewriteEngine on
RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteRule ^.well-known/host-meta /public.php?service=host-meta [QSA,L]
RewriteRule ^.well-known/host-meta.json /public.php?service=host-meta-json [QSA,L]
RewriteRule ^.well-known/carddav /remote.php/dav/ [R=301,L]
RewriteRule ^.well-known/caldav /remote.php/dav/ [R=301,L]
RewriteRule ^remote/(.) remote.php [QSA,L]
RewriteRule ^(?:build|tests|config|lib|3rdparty|templates)/.
- [R=404,L]
RewriteCond %{REQUEST_URI} !^/.well-known/acme-challenge/.*
RewriteRule ^(?:.|autotest|occ|issue|indie|db_|console).* - [R=404,L]

AddType image/svg+xml svg svgz
AddEncoding gzip svgz

DirectoryIndex index.php index.html

AddDefaultCharset utf-8
Options -Indexes

ModPagespeed Off


ErrorDocument 403 /nc/core/templates/403.php
ErrorDocument 404 /nc/core/templates/404.php

So you have access on android and desktop client. But no on the main site.

I suggest you use another approach to install with no shell access there is few we can do to troubleshoot it.

A fresh install of 11.0.2/PHP 7.1 on a server to which I have limited (no sudo) access to occ. The issue with the login button not being active persists. Hmmm.

Also with softaculous?

Try the Web installer

Yes, the install was also with softaculous.

wgeting and manually installing, accepting all defaults (including data directory under public_html) leads to the same outcome… login button that is wholly unresponsive.
On the client side, tried the latest Opera, Firefox and Chrome on Macos 10.12.4.

I believe it’s pretty hard but, sounds like a bug. You might wanna see here.

When i have time i’ll build php-7.1 and test.
I’m using php-7.0.X and it works just fine.


I’ll give is a shot on an OS X machine and a lower numbered PHP when I get a chance, just to reduce variables. I know nextcloud is not supported on that platform… but then I only need the login button to work at this point :confused:

I really appreciate your help thus far!

Isn’t it?
PHP 7.1 is not yet supported?
I didn’t know!

Well, if that’s true, unsupported versions can manifest from one login button or by a complete shutdown of the server. :wink:

Let me know if moving from PHP 7.1 to 7.0 made the difference.
Have fun!

I meant OS X/ MacOs, WTF it is called these days. Sorry about the ambiguity.
PHP 7.1 looks OK:

Oh, ok.
Once i finish other things up, i’ll compile php-7.1

But as you mention it could be your OS.

OK, so here’s where I am at (way to spend a lunch hour, huh?)
Laptop is running MacOS 10.12.4, bog standard Apple PHP and Apache install: Apache/2.4.25 (Unix) PHP/5.6.30.

I pulled down my nexcloud directory from my webhost, changed to config to point out to the mysql db and… DICE! Obvs I am not going to running this off my laptop :smile:

So something is amiss on the server end, and the most I can figure out there is that they compiled Apache themselves (makes sense, I suppose), and also PHP 7.1.3 (compile flags below.) And who really knows what their Linux looks like? They are selling web hosting solutions, not VSes, so I guess I cannot not really complain too much.

I don’t think I can consider this a nextcloud issue at this point, so consider this closed. I will get in touch with the hosting folks and let them know. Suffice to say certain configs do not work. Bummer!

Thanks for your help, @Ark74!!

Preformatted text ‘./configure’ ‘–build=x86_64-redhat-linux-gnu’ ‘–host=x86_64-redhat-linux-gnu’ ‘–target=x86_64-redhat-linux-gnu’ ‘–program-prefix=’ ‘–prefix=/opt/php71’ ‘–exec-prefix=/opt/php71’ ‘–bindir=/opt/php71/bin’ ‘–sbindir=/opt/php71/sbin’ ‘–sysconfdir=/etc’ ‘–datadir=/opt/php71/share’ ‘–includedir=/opt/php71/include’ ‘–libdir=/opt/php71/lib64’ ‘–libexecdir=/opt/php71/libexec’ ‘–localstatedir=/var’ ‘–sharedstatedir=/var/lib’ ‘–mandir=/usr/share/man’ ‘–infodir=/usr/share/info’ ‘–with-libdir=lib64’ ‘–libdir=/opt/php71/lib/php’ ‘–with-sqlite3=shared’ ‘–with-pdo-sqlite=shared’ ‘–enable-cli’ ‘–enable-bcmath’ ‘–enable-calendar’ ‘–enable-dbase’ ‘–enable-exif’ ‘–enable-fileinfo’ ‘–enable-ftp’ ‘–enable-gd-native-ttf’ ‘–enable-libxml=static’ ‘–enable-magic-quotes’ ‘–enable-mbstring’ ‘–enable-opcache’ ‘–enable-pdo=static’ ‘–enable-soap’ ‘–enable-sockets’ ‘–enable-sqlite-utf8’ ‘–enable-zend-multibyte’ ‘–enable-zip’ ‘–enable-intl’ ‘–with-icu-dir=/opt/icu-last’ ‘–with-bz2’ ‘–with-curl=/opt/imh-curl’ ‘–with-curlwrappers’ ‘–with-freetype-dir=/usr’ ‘–with-gd’ ‘–with-gettext’ ‘–with-imap’ ‘–with-imap-ssl’ ‘–with-jpeg-dir=/usr’ ‘–with-kerberos=/usr’ ‘–with-libexpat-dir=/usr’ ‘–with-mcrypt’ ‘–with-mhash’ ‘–with-mime-magic’ ‘–with-mm’ ‘–with-mysql=mysqlnd’ ‘–with-mysql-sock=/var/lib/mysql/mysql.sock’ ‘–with-mysqli=mysqlnd’ ‘–with-openssl’ ‘–with-pcre-regex’ ‘–with-pdo-mysql=mysqlnd’ ‘–with-pdo-pgsql=/usr/pgsql-9.3’ ‘–with-pgsql=/usr/pgsql-9.3’ ‘–with-pic’ ‘–with-png-dir=/usr’ ‘–with-pspell’ ‘–with-tidy’ ‘–with-ttf’ ‘–with-xmlrpc’ ‘–with-xpm-dir=/usr’ ‘–with-xsl’ ‘–with-zlib’ ‘–with-zlib-dir=/usr’ ‘build_alias=x86_64-redhat-linux-gnu’ ‘host_alias=x86_64-redhat-linux-gnu’ ‘target_alias=x86_64-redhat-linux-gnu’

Glad to know!

Cheers :beers:

Hey, I have the same problem. Did you get it fixed?

Thank you :slight_smile: