Can't login any longer after setting up memory cache

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 14.0.3
Operating system and version (eg, Ubuntu 17.04): Kubuntu 18.04.1
Apache or nginx version (eg, Apache 2.4.25): 2.4.29
PHP version (eg, 7.1): 7.2.10

The issue you are facing:

I’ve tried to configure the memroy cache according to the following instructions. This looked easy:

That didn’t work. Now, I can’t login to Nextcloud any longer. I get to the login screen, and can enter my name/password, but when I click on “Anmelden” (login), nothing at all happens.

I’ve restored the /var/www/html/nextcloud directory from a backup, but it stayed the same.

I couldn’t find any corresponding messages in /var/log/apache2/.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

Add caching to a working nextcloud installation according to the link above.

The output of your Nextcloud log in Admin > Logging:

I can’t get there any longer! See above.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'XXX',
  'passwordsalt' => 'XXX',
  'secret' => 'XXX',
  'trusted_domains' => 
  array (
    0 => 'localhost',
    1 => '',
  'datadirectory' => '/var/www/html/nextcloud/data',
  'dbtype' => 'sqlite3',
  'version' => '',
  'overwrite.cli.url' => 'https://localhost/nextcloud',
  'installed' => true,
  '' => false,
  'maintenance' => false,
  'mail_from_address' => 'post',
  'mail_smtpmode' => 'smtp',
  'mail_domain' => 'XXX',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'XXX',
  'mail_smtpname' => 'XXX',
  'mail_smtppassword' => 'XXX',
  'mail_smtpport' => '25',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpsecure' => 'ssl',

  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => 'true',
  'redis' => 
  array (
  'host' => '/var/run/redis/redis-server.sock',
  'port' => 0,
  'timeout' => 0.0,

The output of your Apache/nginx/system log in /var/log/____:

Trying to login doesn’t produce any messages in /var/log/apache2/error.log.


I’ve found out, what went wrong. I had the Firefox YesScipt2 browser addon active. This blocked all the scripts on the page.