Can't login after VM install

vm
#1

I’m trying to install Nextcloud by opening the latest Hannsonit Nextcloud VM using the VMWare Workstation 15 Player.

At the end of the process the scripts ask me if I want to replace the default username and password which and I did but when the system automatically reboots and I try to log-in using the new username and password it says “Login incorrect” even though I user the username and password I changed to in the script process. I did use a password that was common and had to make it more difficult but would that cause a problem logging in?

I can successful browse to the DNS address and I see the Nextcloud webpage so I successful setup the server it seems.

Thanks for any tips.

#2

you used the common password? or did you change it?

if you can login to the servers shell you can use occ to reset and change the admin password.

https://docs.nextcloud.com/server/16/admin_manual/configuration_server/occ_command.html?highlight=occ#user-commands-label

1 Like
#3

I changed it. How do I login to the servers shell? In the Player I’m stuck at a screen that says
Ubuntu 18.04.2 LTS nextcloud tty1

nextcloud login:

When I send ctrl-alt-delete it just reboots the VM but the scripts run after the reboot and I wind up back at the same place asking me for the nextcloud login:

#4

https://docs.hanssonit.se/s/W6fMouPiqQz3_Mog/virtual-machines-vm/d/W6fMquPiqQz3_Moi/nextcloud-vm

did you type the password in the vmware player console? are you sure you haven’t been fooled by the keyboard mapping?

btw: the creator of the vm is also here n the forum. @enoch85 :wink:

1 Like
#5

Thanks. Yes. I typed it in in the console. keyboard mapping seems fine. Hoping @enoch85 will have an idea! :slight_smile:

#6

Hi,

We already emailed about this. I see no other issue than you typing the wrong password. As I said before. use a simple password like “nextcloud” or whatever during the first setup, to be sure that everything works. You can always change the password later if you want.

Also, as I mentioned before; the user for UNIX is always the same (ncadmin) and the user for Nextcloud Web GUI login is your own as you choose one during the first setup.

So if you have issues logging in to the console, did you mix up the users?

#7

@jimchoumobile how did it go?

#8

I reinstalled again and now it’s working. I think the separate user for the UNIX and the Web Admin along with a complex password must have confused me. Thanks very much for the help! Very excited to get started with Nextcloud!

#9

Hi, So while I can log-in now via the console AND I can get to the nextcloud landing page when I go over the Internet to https://myurl.com when I try to use the Nextcloud Mac client to go to https://myurl.com I get the following error: Failed to connect to Nextcloud at https://myurl.com: Server replied “400 Bad Request” to “GET https://myurl.com/status.php” Any guidance on what I should do?

#10

Ok, so you used the SSL script in the VM to setup a domain?

#11

Yes. I used the script to set up SSL. That said, when I did the script where I had to enter the domain it said that it didn’t work and that I should make sure I had port forwarding setup properly (it was already setup). I then continued and after the reboot I was able to reach the dns address over the web as I mentioned earlier.

#12

So just to make things clear here;

  1. You can’t login to the Web GUI?
  2. You can reach the site with your DNS record?
#13

When I started I was able to reach the website with my DNS record. But I wasn’t able to connect using the NextCloud Mac Client. Now things have degraded somewhat in that I can’t reach the website with the DNS record. It now says " Access through untrusted domain
Please contact your administrator. If you are an administrator, edit the “trusted_domains” setting in config/config.php like the example in config.sample.php." I think something got messed up when my network dynamically reassigned the IP address to my NextCloud virtual machine. I’ve fixed it so the IP address is now fixed and the same as what it was before but now I get that untrusted domain message when I try to go to my URL (https://thereoughtabeaword.com). I’ve reset the port forwarding so that should be working properly too. I can get to and log-in using the IP address. Do I need to change the config file? Not sure why I have to change it now as it was working for. Nevertheless, if I do where is it? I can’t find it in the file hierarchy. Thanks.

Further information how to configure this can be found in the documentation.

#14

OK, that explains it. Thanks. So I guess it was a configuration issue all along?

To add you domain as trusted domain, you need to edit /var/www/nextcloud/config/config.php and add your domain there. Don’t forget to change overwrite.cli as well.

The SSL script in the VM takes care of that for you, but if you changed the domain manually you have to change the config manually as well.

Hope it helps!

#15

Indeed it did! Everything is working now. Thank you so much. Very cool. Next challenge - getting DDClient working! :grinning:

1 Like