Can't login after 11.0.3 update

We get the login screen, but this after entering credentials:

Internal Server Error

The server encountered an internal error and was unable to complete your request.

Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.

More details can be found in the server log.

Technical details
Remote Address:
Request ID: 9QZDHHwiXWjRwCMIDy2S

Just read the message :wink:

Yes, thoroughly informative. Especially the part about checking the “server log”. A specific log and location would make that more doable.

check data/nextcloud.log

/var/www/nextcloud/data is empty

Then I’d recommend to use your old backup

I found the log file in /var/ncdata

The problem is with LDAP/AD integration. I can login with the integrated admin account but the LDAP settings show “Configuration Incorrect” even though they were previously working (prior to the upgrade).

The log has a lot of things like this:

02T15:00:01+00:00","method":"--","url":"--","user":"--","version":"11.0.3.2"}

{“reqId”:“DXEyWF0LR/b+QEMmIMvO”,“remoteAddr”:"",“app”:“core”,“message”:“Error while running background job (class: OCA\User_LDAP\Jobs\CleanUp, arguments: ): {“Exception”:“OC\\ServerNotAvailableException”,“Message”:“Lost connection to LDAP server.”,“Code”:0,“Trace”:”#0 \/var\/www\/nextcloud\/apps\/user_ldap\/lib\/LDAP.php(368): OCA\\User_LDAP\\LDAP->processLDAPError(Resource id #507)\n#1 \/var\/www\/nextcloud\/apps\/user_ldap\/lib\/LDAP.php(295): OCA\\User_LDAP\\LDAP->postFunctionCall()\n#2 \/var\/www\/nextcloud\/apps\/user_ldap\/lib\/LDAP.php(46): OCA\\User_LDAP\\LDAP->invokeLDAPMethod(‘bind’, Resource id #507, ‘ldap’, obscured\n#3 \/var\/www\/nextcloud\/apps\/user_ldap\/lib\/Connection.php(613): OCA\\User_LDAP\\LDAP->bind(Resource id #507, ‘ldap’, obscured\n#4

Ah I see :slight_smile:

Then I’d file an issue on https://github.com/nextcloud/server/ and ask for help. Maybe it’s a new requirement or regression

I got it working.
I substituted the IP of the AD server in place of its name.
I removed the symbols from the LDAP access account password.

So it was either a name resolution issue or a new problem using passwords with symbols, or both.

Great to hear, can you mark the post as solved?

I don’t see a way to do that.

Digging deeper it looks like the update reset the DNS servers on the host from internal to Google, so internal host names were not resolving. I don’t see why an application update should be fiddling with DNS settings…