Can't install Nextcloud Hub (v18) On Ubuntu with secondary disk


I would like to test the last version of Nextcloud, which includes ONLYOFFICE.
I tried the install script (as explained here) in order to set things up in a new fresh Ubuntu install.

When prompted in the script, I choose to Automatically configure 2 disks

But then, I get the following issue:

It seems like your VMware secondary volume (/dev/sdb) does not exist.
This script requires that you mount a second drive to hold the data.

Of course, I already attached a new disk to my VMware VM (hosted on ESXi).
I also tried to format it in ext4 and mount it, but still get the same error.
You can see below that the disk sdb and its partition exist:

I don’t know if it’s important to know but it seems that the script unmount my secondary disk since it’s up before running the script but then, it doesn’t appear anymore in my “fdisk -l” result command.

Why do I get this error?
Should I set up the ZFS partition myself?
Is it a bug from the script?

Thank you for your help!

I do not know the script, have never used it and never used VMware, so this is just a guess:

  • Is it possible for the user running the script to access /mnt/ncdata with write permissions?

Yes it is since I launched the script with “sudo”


Just add the disk, don’t pre mount it. If it doesn’t show up in fdisk, then something is wrong with your setup.

The only thing you should need is to add the disk in VMware, start the script, and everything is taken care of.

If you need help with installing, you can choose between the pre made VMs:

Or installation from scratch:

FYI - I get the same error when adding a ZFS ‘partition’ (actually, it’s just a folder reference with quota) using ProxMox 6.1-17. The ‘disk’ shows up nicely in the LXC instance:

admin@nextcloud3:~$ df -h
Filesystem                    Size  Used Avail Use% Mounted on
rpool/data/subvol-101-disk-0   20G  2,8G   18G  14% /
rpool/data/subvol-101-disk-1  200G  216M  200G   1% /mnt/ncdata

AFAIK, there’s no way in ProxMox to add ‘raw’, unformated disks to LXC VM’s, and there should be no need to.

It would be nice if the script acted a little more intelligent (or perhaps, less intelligent?) on the actual presence of secondary ‘disks’, especially if one chooses the option ‘2 Disks Manual’.

That looks like the key difference from what I can tell. In the screenshot, /dev/sdb has already been partitioned, formatted, and mounted to /mnt/ncdata.

1 Like

@enoch85 - quick question. I’m having a similar problem with the script not picking up a second drive. Am I right in assuming that it’s looking for “sda” and “sdb”?

Because I’m using /vda and /vdb and whether i use the manual or automatic 2-disk option, neither way will pick up that I have a second drive. fdisk is quite happy that it is there, and not mounted, but the script doesn’t want to see it.

Happy to try a workaround if there is one, otherwise I can just burn this VM and create a new one using SATA emulation as opposed to VirtIO.

Thanks very much.

You can check the logic in the scripts:

If it doesn’t work, please try the manual option - or send a PR to improve the current logic.