Can't install Collabora Online plugin on an upgraded Nextcloud 19 install


I have just moved my server from 18.0.11 to 19.0.4 and was trying to get CODE functionality to work. I can install the CODE plugin itself without issue but when I try to install the Collabora Online plugin itself, I get the following errror.

"Column name “oc_richdocuments_wopi”.“remote_server” is NotNull, but has empty string or null as default. "

I had previously tried to add a CODE install into my docker-compose.yml under Nextcloud 18, but had never got it working, and it may be that this is some artifact of that failed attempt. What is the easiest way to sort this out so that I can install the plugin, please?

Check the github repo for the project, along with their documentation. I know the project is under heavy development. Also, you’ll want to share details on your actual setup.

1 Like

Is anyone able to offer some slightly more helpful advice than RTFM, please? Happy to provide any additional information that is contextually useful.

Happy to report that I have been able to find a solution. Looking at the github documentation regrettably provided no help or insight. Logging interactively into the mysql database and dumping the “oc_richdocuments_wopi” table revealed a piece of ancient configuration that could have dated back to when this was an owncloud install on a different machine several years ago. The thread at related to a different problem, but in fact one of the solutions suggested here worked for me. Editing the database as follows from the mysql interface seemed to fix it.

drop table oc_richdocuments_direct;
drop table oc_richdocuments_wopi;
drop table oc_richdocuments_assets;
delete from oc_migrations where app='richdocuments';

After this was done, the Collabora online plugin installed successfully.

I can’t seem to get my nginx config to allow CODE to run despite making the addition suggested in the plugin config, but that is perhaps another issue.

Hope someone finds this useful.