Can't get .well-known/nodeinfo warning resolved and waiting on background ssl check

Nextcloud version 21.0.3
Operating system and version Ubuntu
Apache or nginx version Apache/2.4.41
PHP version 7.4

The issue you are facing:
I have been able to clear the admin warning for /.well-known/webfinger but am unable to resolve it for /.well-known/nodeinfo. I am using Apache on the Nextcloud VM and NGINX as a reverse proxy on my OPNsense VM and I am using it to rewrite to but in Firefox I get “Firefox has detected that the server is redirecting the request for this address in a way that will never complete.” I have webfinger setup to point to and it resolves to the json response page without issue. I’ve been trying to search the issue myself and have even gone as far as running a recursive grep through the nextcloud folder to see what it shows. When doing this for webfinger I get 5 results back with one pointing to lib/public/Http/WellKnown/IHandler.php but when I check nodeinfo I only get the results for the .htaccess file and the admin.js file. I feel like I’m missing a result that should help my system point to nodeinfo once I set the url redirect properly. Has anybody encountered this particular issue and found a solution? I’ve found that the .htaccess in my nextcloud directory doesn’t really help at all since webfinger is commented out there and it still resolves properly.

Additionally I have the “A background job is pending that checks for user imported SSL certificates. Please check back later.” error displaying as well and have already tried installing Talk then doing the disable/enable trick with no luck on that.

1 Like

I finally got the background job pending notification to go away after setting up the crontab to run instead of using AJAX so for anyone who has that issue as well I’d recommend checking the documentation about setting up the cron job on the system.
Still have made no progress on the nodeinfo issue after 3 hours of working on it last night though.

I tried a quick download of the newer versions of nextcloud from the install site for 22.1.0 and did a grep through the freshly unpacked tar and found only 1 entry for nodeinfo in it as well. So I’m clearly missing something about how to get this working so any thoughts or tips for this would be greatly appreciated at this point.

Please refer to:
Link shows how to solve this issue by SQL dbadmin request.

Look at:
Add to .htaccess (regarding to your installation path):

Redirect 301 /.well-known/carddav /owncloud/remote.php/dav
Redirect 301 /.well-known/caldav /owncloud/remote.php/dav
Redirect 301 /.well-known/webfinger /owncloud/index.php/.well-known/webfinger
Redirect 301 /.well-known/nodeinfo /owncloud/index.php/.well-known/nodeinfo

Maybe it helps!?

God luck and regrads.

I’ve actually got that redirect done on my external nginx and it points to the /nextcloud/index.php/.well-known/nodeinfo but it causes a ton of redirects apparently since that’s not resolving properly or something along those lines. I can see the redirect in my browser though so now that the redirect there something else seems to be missing once it hits that url as best I can tell. It never goes to the json response(I assume it’s a json response like webfinger) so I’m wondering if something else is missing in a file somewhere that tells it how to handle that well-known request.

While calling redirected url webfinger or nodeinfo in FF-90 browser json responds “not supported”.
So is it working for Apple/ Mac, or isn’t it???

OK, That worked 4 me

Webfinger works fine while NodeInfo fails to redirect when setup in the same redirect manner as Webfinger.
Screen Shot 2021-08-18 at 1.16.16 PM

They are both being passed through the same NGINX config on my OPNsense just having the end URL adjusted for whether it is Webfinger or Nodeinfo.