Can't get NC Talk video chat works over local network with https

Hello good people.
Recently I installed Nextcloud on my home server with intention to use only on local network just for 5-10 devices. Everything seems working great except Talk. When I try to make video call to any of participants ring in a middle of chat window is just spinning and never connects. Text messaging works though. After some research I presumed that may be build in STUN is not enough and I installed TURN server with coturn. But this didn’t help. Nextcloud talk is Spreed which is use WebRTC. Then I tried bunch of simple apps from github with WebRTC implementation just to see if this is my server setup causing problem. “”, “decentralized video chat” to name few. So, none of them works on local network. Also tried Briefing - Secure direct video conferencing , and few similar websites and none of them work if I started chat on one computer in my network and try to join on another on a same network. I tried Chrome and Firefox browsers, all latest versions. Then for experiment I disabled firewall on my server (centos) where is NC is installed and that’s finally explain why Talk wasn’t working. So audio and video on Talk went through as it should. So turned back firewall on open ports 3478 UDP&TCP And range 49152-65535 for UDP.
I was happy for one day :slight_smile: Then next of my task was get rid of annoying web browsers security alert of non https website. So I installed let’s encrypt and successfully certified my server. Alert is gone and everybody can access nextcloud by domain name. And Talk stopped working again.
By today I spent like three days of my free time already to troubleshoot this problem. So I disable firewall again just to be sure it is not the old port blocking thing. Was playing with coturn settings, tried what ever made sense to me. And now I’m out of ideas.
So if I disable redirection to https version of nextcloud and login to http Talk is working again, as soon as I login to https it’s stop.
What could be a cause this. I will greatly appreciate any help.
Thank you.

I have the same issue. Everything worked fine within and outside of my local network using a coturn server. Either a Nextcloud or Ubuntu/Debian update broke something within Talk. Now I can not use Talk within or outside my local network. No matter the firewall settings. I have not tried disabling HTTP but I do not want my traffic to be unencrypted so. There is also one other guy in my thread that has the same issue.

So I’m not alone on this. Being checking all logs I can think of to troubleshoot it. No idea where to go next :slight_smile:

I was able to resolve the issue. The update 20.0.7 solved the issue. Then I still had issues with certain connections. After having reinstalled my Google Chrome, everything worked fine again.

Me too. But my problem wasn’t fixed by update. A have zerotier network in all my devices and seems like turn server had problem to connect if both devices are in virtual and local networks simultaneously. I figured this by checking browsers console and webrtc internals. Now I have to find a way to fix it.