Can't get into my Nextcloud, neither locally nor through nginx

Hi there,

since monday last week I have an issue that I can’t get my head around. I hope I can provide proper information on the case, I’m not very good with these kinda “admin” things :frowning:

I run a Nextcloud on my unRaid server, through the linuxserver Docker container. A few users are on there (which is why I don’t want to start everything over). Last monday (31.10.) I noticed my auto-uploads for photos were not working anymore; I didn’t update the server manually (there’s no auto-update enabled) and it happened “over night”, no idea why. First I tried updating all dockers (which I don’t do that often), but that didn’t help.
It worked flawless for half a year.
I use mariadb and NginxProxyManager for the DDNS, both also docker containers.

When I try to reach my Nextcloud either through the local IP or the DDNS, I get an ERR_CONNECTION_REFUSED. I can not get into the webinterface. Logs for all dockers don’t serve any errors.

According to the version.php, Nexcloud 24.0.6 is currently installed, but I’m not sure if that’s accurate.
OS is unRAID 6.9.2, docker container is nextcloud by linuxserver (also not sure with version; right now it’s set to the repo :latest, but :24.0.6 and 24.0.5 also didn’t work).
For PHP version, I have no idea how to get that info :frowning:

Here’s the config.php, I hope I properly redacted revealing info:

$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'datadirectory' => '/data',
  'instanceid' => 'ocme13n05qve',
  'passwordsalt' => '###',
  'secret' => '###',
  'trusted_domains' => 
  array (
    0 => '192.###',
    1 => '###',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '###',
  'overwritehost' => '###',
  'overwriteprotocol' => 'https',
  'dbname' => '###DB',
  'dbhost' => '192.###:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'oc_###',
  'dbpassword' => '###',
  'installed' => true,
  'default_phone_region' => 'DE',
  'mail_domain' => '###',
  'mail_from_address' => '###',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_smtpsecure' => 'tls',
  'mail_smtphost' => '',
  'mail_smtpport' => '25',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtpname' => '###',
  'mail_smtppassword' => '###',
  'maintenance' => false,
  'loglevel' => 2,
  'theme' => '',

Regarding nginx/system logs, I’m not sure which ones to get, and where they would be.
In nextcloud\log\nginx are some, are those the ones?

I’m sorry I only have vague information on everything. I’m not good with this stuff and I’m freaking out a little because I can’t get it to work anymore. Any pointers, also to learn what exactly goes wrong here (or where to find out) would be highly appreciated.
I tried asking in the unRAID forums first, but seemingly no one can help me out there

Best Regards

Typically this means you connected to a TCP port that isn’t open, and it responded with a reset.

Is NginxProxyManager what listens on the port you connected to?

Maybe you can run ss or netstat and verify the port is open on your system first.

1 Like

another upgrade gone wrong. the upgrade process for NExtcloud is abysmal. I have the same issue and no one from Nextcloud even bothered to reply. If this is the level of support and a product being sold to Enterprises…good luck

No you don’t…

Hi there KarlF12,

for what it’s worth, I set the ports inside my FritzBox. For Nginx, it needs to route 443 → 18443 (for HTTPS) and 80 → 1880 (for HTTP). I created an all new DDNS and linked to a different docker container for a test yesterday, that worked as expected.
Would the ports matter for local access? Because I can’t get on through LAN either :o

Unfortunately I am really, REALLY bad with all things that involve a console. How (and where) do I use the ss/netstat commands, on my unRAID, or my PC…? I’m sorry :frowning:

Hi pk198105,

I didn’t upgrade, that’s the thing here. I only do it manually and didn’t upgrade anything before it stopped working.

With an attitude like that, I’m not surprised. Except someone did actually respond on your thread. You were quite rude there as well.

Please don’t hijack someone else’s thread to complain.

I’ve never used Unraid so I can’t give you any Unraid-specific guidance, but it sounds like something isn’t running.

1 Like

really?! maybe the attitude of support should be better especially if they are marketing it as the next coming of christ. i only got a response after having to resort to responding in other threads. If you are not going to support a product because it is not installed in mainstream maybe dont market it as such and dont offer other platforms

You’re talking to fellow users here who don’t owe you anything. I suggest you be nice if you want help.

1 Like

but it got you to FINALLY respond!

which was a mistake, as I now have to admit.


great COMMUNITY SUPPORT!!! you win!!!

Hello @pk198105 ,

We consider your attitude in this post also against our code of conduct. This is your second post where we warn you, which means if we warn you a third time we will not continue to welcome you on our volunteer forum.

Daphne (Manager Alliances, Ecosystem & Support at Nextcloud).


@LucMeister Sorry for the disturbance… Did you check that all your Docker containers are in the running state? I’m not sure about unraid but on other systems you would run docker ps to check.


Hi there Karl,

I have to admit I was kinda anxious when I saw I have 15 eMails from this thread, things got wild, haha :slight_smile:

So, no I’m absolutely not sure why, but it runs again. This morning after I wrote my answer on this forum, I ventured very shortly into Nginx and my DDNS settings, trying different things here and there. I don’t know what I did, but suddenly one of the Nextcloud tabs I had in the background showed my Nextcloud. By then I already changed what did the trick and was not able to get into it again, however it showed me that Nextcloud is indeed running and somehow only the forwarding is broken (which is really frustrating because even locally, the DDNS gets loaded when I type the IP).

After work I got back to it and wanted to check things with a test-DDNS and a different docker, which worked out. I tried to route my Nextcloud DDNS to a different docker, which didn’t. I was close to just delete the whole forwarding and set it up new again, but then I activated a few things inside the Nginx settings (I believe it was HTTP/2 Support, HSTS Enabled, and Websockets Support) and it worked like it was never an issue. I have no idea what these options do, but I guess it’s nothing that does any harm, huh?

Thank you so much for staying with me. Now I want to find out how to backup my Nextcloud and mariadb through unRAID so I can Upgrade to v25 soon, but that’s a topic for a different day :slight_smile: