Can't get Collabora to function in a Snap install

Hello, I am new to Nextcloud and so far everything has been wonderful and simple. I installed Nextcloud with the Snap package on Ubuntu and the only issue that I have is getting Collabora to work. I installed the app and went into it’s settings and pointed it to my server (I am testing this all in a virtual machine) and when I try to edit the sample document I just get an error.

I have tried restarting the virtual machine, which would restart the server and still same error. I have tried specifying port 80 as I understand that is the default port used in the Snap package. I can’t seem to find any information pertaining to installing Collabora specifically for the Snap install of Nextcloud and was wondering if someone could offer me some insight?

I greatly appreciate any responses, thanks in advance!

Looks like I missed the fact that docker needs to be installed and a bunch of setup needs to be done. None of the guides that I can find look the same and none of them seem simple. Most seem to require a domain name, which I do not have on this setup.

Anyone know an easy way to get this working? It’d be nice if there was a Snap package for Collabora too.

Did you manage to set up snap and office? i have the same problem

1 Like