Can't download federated shared files

Nextcloud version: 14.0.3
Operating system and version: Fedora 27
Apache or nginx version: Apache 2.0
PHP version: 7.1.22

The issue you are facing: I can’t download nor re-share any file I’ve received as a federated share. I’ve tried to check all possible logs and can’t find a clue at all. I’ve tested with different servers, even in the same version than mine, but no luck. I’ve even thought that it’s a SELinux issue, but if I disable SELinux I’m getting still the same.

Users on other servers can access my files if I share them to they as federated too, and even edit.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Receive a federated share from other server
  2. Try to download it or open it

The output of your Nextcloud log in Admin > Logging:

Not related, actually it’s all old logs, but here it goes anyway:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

The output of your Apache/nginx/system log in /var/log/____:

I also must say that I’ve even shut down SELinux and Firewall, just to see if some of them are blocking something, but the result is still the same.

I found the problem. I don’t know why, but I have the app of compatibility with Google Drive, and had checked the option of compatibility with Mac NFD. I just uncheked it and done! Now I can use federated files.

I leave this here just in case somebody in the world get the same issue :sweat_smile: