Cant delete trashbin (->false memory shown?)

I have a Nextcloudpi server running and everything works fine.
I have round about 150 Gb of data on it. The Harddrive has 2.8TB.
Im synchronizing at the moment abou 1600 Gb trough the windows client on the server. (getting some errors over time but overall working. Im adding them over the windows client because I want them to be encrypted)

My Problem:
When I run the command df -h , the pi says there is 81% used of the Harddrive. (Size: 2.7T; Avail:2.3T)

Is this just reserved space for the huge files? How can I correct this?

(The Disk has been completly formatted by the nextcloud wizard at setup)

I hope somebody can help me?

m also getting this errors in the log:

Fatal webdav Sabre\DAV\Exception\BadRequest: expected filesize 10485760 got 7168000

When I try to load the trashbin (I deleted the huge files) It wont open. This is (as it seems) a common problem.
So I tried following command to get rid of the files in the trashbin:

sudo -u www-data php occ trashbin:cleanup --all-users

BUT I get following error:

Could not open input file: occ

I already updated to the Version v15.0.4 because I readhere it should help, but I still get following error in the log:

Error	remote	TypeError: Return value of OCA\Files_Trashbin\Sabre\AbstractTrash::getSize() must be of the type integer, float returned	

(looks a bit like a one man show, I hope somebody will tune in to answer some of my questions…)

What can I do to solve this Problem? (=How can I delete my trashbin?)

I found a solution. It is not pretty but it seems to work:

The only way you can get rid of these huge files/data, is to delete the complete user with the admin account. The raspberry pi is deleting then all the files and the free memory on the disk should start to grow.
(You can look it up with df -h )
(to update the free space you have to type in the command multiple times…)

Maybe this helps someone.

Hello, i have the same problem.
But I think the path for trashbin:cleanup is wrong.
I don’t want to delete the user, because I must copy 40GB a second time to my account. I installed the software on a raspberry 3.
Did anybody knows the correct path and command to clean it up?
Sorry for my english , it’s not the best .

What happens when you enter the command?
Error message?

Following should work normally:

sudo -i

cd /var/www/nextcloud

sudo -u www-data php occ trashbin:cleanup --all-users

Great !!! Thank you very much for the answer .
It works.
The problem was that I haven’t root right until sudo -i.
After that it I use your solution and now it works normally.