"Can't create or write into the data directory" during Synology install

Hi there,

New user to Nextcloud trying to get installed on Synology. I’m using Nextcloud 19.0.0., MariaDB 10, PHP 7.2, Apache 2.4, and not using Docker. I’ve succesfully installed and configured Nextcloud keeping all folders and files in default locations in web folder. However when I try to do a fresh install changing the data folder to an external location I get the error “Can’t create or write into the data directory /volume1/data/nextcloud”. I’ve been reading everything trying to figure out how to fix this and having no success.

I’ve used SSH to run the following commands on my data directory:

sudo chown -R http:http volume1/data/nextcloud/
sudo chmod 0750 volume1/data/nextcloud/

On the install screen I set Data Folder to:

/volume1/data/nextcloud

I’ve tried making the owner “http” and given the group “http” full access using File Station and it hasn’t helped.

But I keep getting the error when I try to install. Can someone give me some advice on what I’m missing?

Thanks for any assistance!

Have you solved this problem yet? I have the same

I am having this problem too with version 20.0.2. After a fresh installation and with only one account added, user data files do not seem to be write enabled via the software. The permissions from the OS are correct, and the .htaccess files are generated per the nextcloud install script. The webpages look fine, but if you try to upload a file or update most user settings an error message stating something like “There was an error saving the mode” appears. Can add and remove user accounts, but users can’t do anything once logged in. This is on a vanilla install using Softalicious.

Messages in the past with similar issue seem to have been resolved by editing the .htaccess file in the userdata, but my install has the recommended apache directives.

Any ideas on how to proceed?

This was fixed by editing the top level .htaccess file. The settings were too restrictive