Can't connect Nextcloud 14.0.4 to OnlyOffice : GetConvertedUri

Hello,

I have a Nextcloud server (cloud.mydomain.com) and a OnlyOffice DocumentServer with Docker on the same host (mydomain.com:8443)
All with nginx.

I can access to nextcloud and to OnlyOffice welcome page, no problem.

When I config the OnlyOffice connector on Nextcloud, I put :

But, when I validate, I have this error : “error while downloading the document file to be converted”

And when I see the logs :

Have you got some ideas ??? thanks

1 Like

does your dns provider forward https requests to port 8443 ?
Do you use reverse proxy?

Pretty common error. Many solutions are possible. Have a look at https://github.com/ONLYOFFICE/onlyoffice-owncloud/issues/181 for example.

I have the same problem. OO worked until I upgraded to NC 14.04. After that I get this problem. I had the same installation. Nothing changed execept the upgrade. I have NC installed with nginx, and OO in docker.

I have followed this instructions for installation https://www.c-rieger.de/nextcloud-and-only-office-nginx/

I have domain name from dedyn.io. NC and OO are on the same server with the same domain-name

MY certificate from Lets encrypt is in order as far as I can understand

I have copied my certificates as below

mkdir -p /app/onlyoffice/DocumentServer/data/certs
cp /etc/letsencrypt/live/your.dedyn.io/privkey.pem /app/onlyoffice/DocumentServer/data/certs/onlyoffice.key
cp /etc/letsencrypt/live/your.dedyn.io/fullchain.pem /app/onlyoffice/DocumentServer/data/certs/onlyoffice.crt
cp /etc/ssl/certs/dhparam.pem /app/onlyoffice/DocumentServer/data/certs/dhparam.pem

I have revised /var/www/nextcloud/config/config.php and added:
‘onlyoffice’ =>
array (
‘verify_peer_off’ => TRUE,
),

I have tried to modify the default.json to set rejectUnauthorized to false and restart services

Still same problem. What more can I do?

Remains one proposed solution: “solved it by adding the Document Server to the trusted_domains -array in the /var/www/html/config/config.php of the nextcloud installation.”
I do not understand how to do that as the OO is in a docker on the same domain-name as NC.

So I finally got this working!

I had also set ‘verify_peer_off’ => TRUE, (in /var/www/nextcloud/config.php) & went into my docker container for only office (docker exec -it only_office bash -> nano /etc/onlyoffice/documentserver/default.json)
I set the value of the parameter “rejectUnauthorized”: from true to false

Still no good. So I installed letsencrypt, got me a self signed cert, and now proxy from port 9080 (ssl) to port 9050 (unencrypted OO server port)

This is my nginx config:

server {
listen 9080 ssl;
ssl_certificate /usr/local/ispconfig/interface/ssl/ispserver.crt;
ssl_certificate_key /usr/local/ispconfig/interface/ssl/ispserver.key;
ssl on;
location / {
proxy_pass http://127.0.0.1:9050;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header Host $http_host;
proxy_set_header X-Forwarded-Proto https;
proxy_redirect off;
proxy_http_version 1.1;
}
}

I’m reusing my ISPconfig key, but you can use any SSL key, or make a new one.
Then I use https://127.0.0.1:9080/ for my Doc Editing Service addr - and presto!