Cant add custom directory

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 18.0.2): 3.13.1
Operating system and version (eg, Ubuntu 20.04): Android 8.0 /e/os
Apache or nginx version (eg, Apache 2.4.25): ?
PHP version (eg, 7.1): ?

The issue you are facing:
I just started to use nextcloud but already face an issue.
I have a directory called documents in my phone which i would like to sync in nextcloud.
When i go to the nextcloud app ,i see a documents directory but it isnt my own phone documents directory. Inside the documents directory of nextcloud are only documentation of nextcloud inside it. When i try to add a custom directory (my own documents directory) the add button is grey/blank. So i now need to upload my documents one by one manually. My carnet notes get uploaded though. Dont know whats wrong.

Is this the first time you’ve seen this error? (Y/N): Yes

Steps to replicate it:

  1. Go to automatic uploading
  2. Click the vertical 3 dots
  3. Select custom directory

The output of your Nextcloud log in Admin > Logging:

PASTE HERE

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

PASTE HERE

The output of your Apache/nginx/system log in /var/log/____:

PASTE HERE

I dont post logs yet because i think this is a phone related issue or simple setting problem.

What im trying to do now is add my documents folder with subfolders in it to auto sync.
I selected ‘use submaps’, and ‘upload existing files’ but i always get a warning about battery optimalisation and the folders and files wont upload.
When i go to settings>battery>nextcloud , i see that battery optimalisation for nextcloud is turned off