Can't activate SSH from Webpanel

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): replace me
Operating system and version (eg, Ubuntu 20.04): replace me
Apache or nginx version (eg, Apache 2.4.25): replace me
PHP version (eg, 7.4): replace me

The issue you are facing:

I can’t active SSL from the webpanel of NextcloudPi

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. I go the SSL tab on the left
  2. I check “active” and change the password.
  3. I click “apply”

The output of your Nextcloud log in Admin > Logging:

[ SSH ] (Thu Mar 31 20:17:32 BST 2022)
New password: Retype new password:
passwd: password updated successfully
Wrong salt length: 3 bytes when 8 <= n <= 16 expected.
Synchronizing state of ssh.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install disable ssh
The user pi is using the default password. Refusing to activate SSH
SSH disabled

run ncp-update and try again

That worked. Thank you for the quick help.