Cant accessDropbox external link due to missing smbclient

I previously successfully configured dropbox as an external storage.

Now, Nextcloud is complaining about not finding smbclient. Its nowhere to be found on my shared linux server. I assume it used to be there or the Dropbox integration would never have worked.

I cannot seem to remove the Dropbox folder using the web interface.
Also, the desktop client is generating HTTP transmission errors.
How do I remove Dropbox? Hit a database table or config file somewhere?

The output of your Nextcloud log in Admin > Logging:

[files_external] Error: OCP\Files\StorageNotAvailableException: Unknown storage backend "dropbox" at <<closure>>

 0. /home/remotely/public_html/cloud/apps/files_external/lib/config.php line 268
    OC\Files\Storage\FailedStorage->setAvailability("*** sensitive parameter replaced ***")
 1. /home/remotely/public_html/cloud/apps/files_external/lib/Controller/StoragesController.php line 257
    OC_Mount_Config::getBackendStatus("*** sensitive parameters replaced ***")
 2. /home/remotely/public_html/cloud/apps/files_external/lib/Controller/UserGlobalStoragesController.php line 124
    OCA\Files_External\Controller\StoragesController->updateStorageStatus("*** sensitive parameters replaced ***")
 3. /home/remotely/public_html/cloud/lib/private/AppFramework/Http/Dispatcher.php line 170
    OCA\Files_External\Controller\UserGlobalStoragesController->show(2, "*** sensitive parameter replaced ***")
 4. /home/remotely/public_html/cloud/lib/private/AppFramework/Http/Dispatcher.php line 100
    OC\AppFramework\Http\Dispatcher->executeController(OCA\Files_Extern ... {}, "show")
 5. /home/remotely/public_html/cloud/lib/private/AppFramework/App.php line 137
    OC\AppFramework\Http\Dispatcher->dispatch(OCA\Files_Extern ... {}, "show")
 6. /home/remotely/public_html/cloud/lib/private/AppFramework/Routing/RouteActionHandler.php line 47
    OC\AppFramework\App::main("OCA\\Files_Exte ... r", "show", OC\AppFramework\ ... {}, {id: "2",_route: ... "})
 7. <<closure>>
    OC\AppFramework\Routing\RouteActionHandler->__invoke({id: "2",_route: ... "})
 8. /home/remotely/public_html/cloud/lib/private/Route/Router.php line 297
    call_user_func(OC\AppFramework\ ... {}, {id: "2",_route: ... "})
 9. /home/remotely/public_html/cloud/lib/base.php line 1012
    OC\Route\Router->match("/apps/files_ext ... 2")
10. /home/remotely/public_html/cloud/index.php line 37

GET /index.php/apps/files_external/userglobalstorages/2?testOnly=false
from by lyallp at 2020-09-18T02:33:47+00:00

Solved by digging around the Nextcloud database and deleting some rows.

Prior to going SQL mad, I did try on my shared linux server

cd public_html/cloud; php occ files:scan --all

Using phpmyadmin I then went on a deleting frenzy (after making a backup first!)

4 = old data location from when owncloud was installed, not even valid so I cleaned this out as well.
22 = dropbox

oc_filecache where storage = dropbox storage_id

oc_external_* (multiple tables starting with oc_external) where storage = dropbox storage_id