Can't access NextCloud Server from Desktop Client

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): Latest 16
Operating system and version (eg, Ubuntu 17.04): Centos 7 v1803
Apache or nginx version (eg, Apache 2.4.25): 2.4.25
PHP version (eg, 7.1):7.3

The issue you are facing:

Nextcloud is installed in my Datacentre with ip address Installation went smooth and im able to login .

Issue is with Desktop client (Windows 10 Pro). Im on IP range 172.17.x.x Access on port 80 and 443 has been granted to my ip to access the nextcloud server.

I cannot connect to the server. Error is timeout. I have even turned off firewall both on Windows 10 and CentOS.

Any clue please ?

Is this the first time you’ve seen this error? (Y/N): yes

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


The output of your Apache/nginx/system log in /var/log/____:


Have you tried to *ping* the server?
Have you tried to access it using a web browser on port 80/tcp and/or 443/tcp?

If all this works without a certificate error, the desktop app should work too.

1 Like

Hello j-ed. Thanks for your reply.

I can connect to my nextcloud server in my browser via port 80 but not 443.

any advice

If you can connect to your server on one port but not another, then the problem is most likely server-side. Start by using netstat to verify your server is actually listening on 443.

1 Like

Problem solved.

I had to remove proxy settings.

Thank you all


Can you please share the step from where to remove proxy stetting? I’m facing the same issue on mac. Desktop client installation goes perfect but can not connect to my instance. Your help in this regard will be highly appreciated.