Cannot Update to Nextcloud 18 for NCP


When running the updater for Nextcloud 18 on my NCP I get the following error message while the updater tries to create a backup:

Could not copy “/var/www/nextcloud/config/” to “/media/myCloudDrive/ncdata/updater-oc1njr7k29sp/backups/nextcloud-”. Source /var/www/nextcloud/config/ is not readable. Destination /media/myCloudDrive/ncdata/updater-oc1njr7k29sp/backups/nextcloud- is not writable

How can I solve this?

Thanks in advance :slight_smile:

Using nc-update-nextcloud
or Nextcloud native updater?

I’m using the native updater via the admin page of NC.

you should always use the ncp updater.

I’m not sure what you mean by the NCP updater. I consider this to be the native updater:

It seems the issue solved itself overnight via nc-autoupdate-nc
Thanks for your help! :smiley:

I was hoping to see a solution here, because I am actually having an issue with the NCP update to NC18. Does any one have any suggestions?

Wait 10min and try again, NC server maybe getting a lot of requests …

Thank you for the reply. Unfortunately this doesn’t seem to be the issue. I have encountered the issue throughout the day.

I have resolved my issues. The IPv4 address that “” resolves to is listed under an IP blocklist I use. (Hijacked list from iBlocklist, for those interested). Maybe nextcloud obtained new IPs and iBlocklist needs to update their lists. I will submit something to them.

I have the same problem too - file is not writable (checked with access root everyting is fine)


Current version is 17.0.1.
Update to Nextcloud 18.0.2 available. (channel: “stable”)

Create backup

Could not copy “/var/www/nextcloud/config/config.php.bak-29.01.2020” to “/CloudBackupData/updater-ocm4urcft39c/backups/nextcloud-”. Source /var/www/nextcloud/config/config.php.bak-29.01.2020 is not readable. Destination /CloudBackupData/updater-ocm4urcft39c/backups/nextcloud- is not writable

Trying update thru nextcloud/updater/ - till now it worked withou a problem - why now it’s not working ? why need to use nc-autoupdate-nc? if the web /updater/ is not working it should be removed from nextcloud web interface?

this issie have nothing to do with with connection do download server - if Your nc cannot reach update servers the update process will not even start, as You can see I can download the file, yet I have the same issue with file not writable as the author of the topic.

Connecting to (||:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 106544184 (102M) [application/zip]
Saving to: ‘’ 100%[======================================================>] 101.61M 9.92MB/s in 10s

Do not mix threads!! You have different issue than the author


it would be nice if you wouldn’t crosspost your problems… please decide yourself which ones to keep
this one here… or the ofllowing one


Jimmy sure, I’ve realised that i have NC installed from scratch on debian, not NCP