Cannot update and Letsencrypt not working

Hi,

I moved to a new appartement and wanted to setup my Raspberry Pi Cloud again, havent set it up for around 8 months so I wanted to update the Version but it doesnt work, I also cannot create a new Letsencrypt Certificate. I always get those errors:

[ letsencrypt ]
/usr/local/bin/ncp/NETWORKING/letsencrypt.sh: line 65: /usr/bin/letsencrypt: No such file or directory

[ nc-update ]
Downloading updates
Performing updates
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Get:3 https://packages.sury.org/php stretch InRelease [6760 B]
Ign:3 https://packages.sury.org/php stretch InRelease
Fetched 6760 B in 1s (5447 B/s)
Reading package lists…

W: GPG error: [link removed] stretch InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY B188E2B695BD4743
W: The repository ‘[link removed]/php stretch InRelease’ is not signed.
Reading package lists…
Building dependency tree…

I already researched a bit and found out I have to renew the public key. I did try that but it didnt help at all. I am sadly no linux expoert and dont know what to do anymore.

Currently installed is version 1.13.6 for RaspnberryPi, I am using the 3 B+

Had to remove two links in the error log because i couldnt post it otherwise :slight_smile:

your system is very outdated. We have better support for users that don’t update frequently now but that doesn’t apply to you since it’s too old.

I would just do nc-backup and then flash the latest image and restore the backup