Cannot share External Storage to Federated Users

I configured local External Storage for all users in the Admin page:

All users have read access. But all (incl. Admin) get this notifiication when accessing:

“You don’t have permission to upload or create files here”

Now I try to share this External Storage with an Federated User (replaced user and domain with an existing and working one):

And get this error notification:

“Cannot increase permissions of …”
“mucke-share” is the account which wants to share.

The rights on Ubuntu 16.04 for the mounted folder are:

drwxr-xr-x 649 www-data www-data 28672 May 28 15:12 Musik/


When I share an internal folder to a Federated User everything works! :question::question::question:

I am a total noob when it comes to Nextcloud, but just out of curiosity what happens if you give everyone full access rights the the external folder? I know that isn’t want you want, but for testing purposes it might give some answers.

Just tried this:

# chmod -R 0777 ./Musik

drwxrwxrwx 649 www-data www-data     28672 May 28 15:12 Musik/

No change … :disappointed_relieved:

Dang it,

Well at least we know that the issues is somewhere within Nextcloud itself.

Unfortunately I can’t test this on my end because I only have 1 server.

Also a rescan of files did not help:

/var/www/nextcloud$ sudo -u www-data ./occ files:scan --all

Ups … I waited a few minutes, did a rescan again and then: No more error notifications!!!

Now I shared my folder to my federated friend!!! :grinning::grinning::grinning:

1 Like

Just reproduced:

  1. Wanted to share folder ./Filme and got the same error.
  2. # chmod -R 0777 ./Filme
  3. /var/www/nextcloud$ sudo -u www-data ./occ files:scan --all
  4. Error still there.
  5. /var/www/nextcloud$ sudo -u www-data ./occ files:scan <account>
  6. Federated sharing is working.