Cannot Read/Write Tasks Using Evolution

Nextcloud version: 23.0.0
Operating system and version: Linux Mint 20.2
Apache version: 2.4.41
PHP version: 7.4

This summer, I installed Nextcloud Hub II on a Raspberry Pi 4, and I have been using it successfully to synchronize my Contacts, Calendar Events, and Tasks between Evolution (that is installed on my Linux Mint PC) and my Android cell phone.

Recently I decided to move Nextcloud to the Linux Mint PC to free up the Raspberry Pi for other projects, so I have installed the Apache/MySQL/PHP/Nextcloud combination on my Linux Mint PC using the same basic procedure that I used to install it on the Raspberry Pi. I didn’t run into any real issues, so when I finished I began configuring Evolution to access it in the same manner it accesses the Nextcloud instance on the Raspberry Pi (the Raspberry Pi Nextcloud is still running and is still accessible to Evolution as separate Contacts Lists, Calendars, and Tasks).

I first added a new Contacts List in Evolution for the localhost instance of Nextcloud in a similar manner as I did with the Raspberry Pi instance, and it worked as expected (i.e. it would read/write Contacts to/from the localhost instance). Next, I added a new Calendar in Evolution for the localhost instance in a similar manner as I did with the Raspberry Pi instance, and it too worked as expected. However, when I added a new Tasks List in Evolution for the localhost instance and tried to save a “test” Task to the localhost instance, I received this error:
Failed to create a task in the task list “CalDAV: Nextcloud”
Cannot create calendar object: Failed to put data: HTTP error code 403 (Forbidden):
iCalendar objects must at least have a component of type VEVENT[exception][message]supported-

This error is totally repeatable.
I thought it may me a setup issue in the localhost instance of Nextcloud, so I installed the “Tasks” app in the Nextcloud instance (as the administrator, using the web browser on the localhost) and then created (via my browser) a new Task named “test2” on the Nextcloud server. Afterwards, I went back to Evolution and “refreshed” my Task List for the localhost instance, but this “test2” Task did not download to Evolution.

Summarizing, I have an instance of Nextcloud Hub II on a Raspberry Pi 4 that my Evolution reads and writes to fine. I also have a near-identical instance of Nextcloud Hub II on the same PC that Evolution is running on that allows me to read/write Contacts and Calendar events, but will NOT allow me to read/write Tasks. I want to retire the Raspberry Pi 4 instance, replacing it with the localhost instance, but cannot do so until the read/write issue with Tasks is resolved.

For what this is worth, I have never installed the “Tasks” app on the Raspberry Pi 4 instance, so when I access that version (via my browser), I can see the Tasks on its Calendar but can’t really do anything with them (which is fine, because I maintain those Tasks via Evolution and only use the Nextcloud server to pass them along to my cell phone in a one-directional manner).

FYI, when I click the “Refresh” option in Evolution for the “Nextcloud” Task List for the localhost instance, there are no error messages generated in Evolution.

Lastly, I have verified that the URL defined in Evolution for both the functioning “Nextcloud” Calendar and the non-functioning “Nextcloud” Tasks List are identical. Also, it is my understanding that HTTP Code 403 suggests that the connection between Evolution and Nextcloud is fine but the Nextcloud server is rejecting the request. After I create a new “test2” Task and try to save it to the localhost Nextcloud (and get the error), I can immediately save it to the Raspberry Pi Nextcloud instance just fine, which suggests to me that Evolution is sending the exact same information to both instances of Nextcloud, but the Raspberry Pi instance is accepting it while the localhost instance is rejecting it.

Any help will be most appreciated.

There is one significant change that I neglected to mention between the Raspberry Pi instance of Nextcloud and the one I installed on the Linux Mint PC. The Raspberry Pi instance uses MariaDb whereas the Linux Mint instance uses MySQL. I doubt this makes a difference, but I did want to mention it.

I think I found the problem, which has no solution. When I installed Nextcloud on the Raspberry Pi, Nextcloud v22.0.0 was the latest version. However, when I installed Nextcloud on my Linux Mint PC the latest version was v23.0.0. Therefore, I think the problem is related to changes made between v22 and v23. I reinstalled Nextcloud on my PC yesterday with MariaDB instead of MySQL using the exact same procedure I had used to install it on the Raspberry Pi (I know this because I document such procedures for later referral). The problem persisted. Today I am going to uninstall nextcloud v23.0.0 and replace it with v22.2.3 and see if the issue goes away.

Bingo. That was the problem. When I reverted back to V22 of Nextcloud, the problem went away. I am content with Nextcloud v22.2.3, so I do not need a solution at this time.