Cannot login with iOS client 2.25.5

Since upgrade to 2.25.5 (or possibly 2.25.4, I didn’t use the app that often), the app crashed on startup. Accessing Nextcloud from “Files” app still worked. As per the “Problem with App Nextcloud for iOS” thread, I deleted the app and reinstalled it.

Now the issue is I cannot login to the server. I tried two different servers, where login still works from web browser, as well as from Nextcloud Talk iOS app (I deleted the account and recreated it in the Talk app). I tried scanning the QR code for an app password, I tried copy-pasting the app password (directly in the app), I tried using the “web login method” and pasting there the app password, I tried using the general (not app) password. The error message given is (where “\n” stands for a newline, not literal backslash-n: “It is not possible to connect to the server at this time.\nforbidden.”

One server is not run by me, I’m not sure what version exactly it runs. Cannot find that information.

The other server is run by me, and the versions.php file contains:
version.php:$OC_Version = array(17,0,2,1);
version.php:$OC_VersionString = ‘17.0.2’;
(so is that version 17.0.2.1 or 17.0.2?)

I also confirm that logging in from the same iPad to the same Nextcloud server from the same Internet connection (same WiFi network at same location) works from Safari web browser.

The iPad has iOS 13.3, it is model A1674 (MLYM2NF/A).

Also to be absolutely explicit, I had successfully logged in with older app (and slightly older server, maybe 17.0.0 instead of 17.0.2?) from same iPad; all was working well before app upgrade.

Half a day later, I just used Nextcloud in the share menu, and it worked. Going to the app now shows me logged in. Mysterious, but now it works.

I also have this problem.

iOS client 2.25.5 and both 17.0.2 and 17.0.3 server versions. Trying to sign into the app by creating an app-specific password and scanning the QR code in the app produces the error

“It is not possible to connect to the server at this time. forbidden”

Trying to log in using a username and password produces a “Grant access” button, which when pressed shows a spinner for a very long time until it reverts back to the login dialog.

All my other clients work fine - android, the windows, iOS, and ubuntu sync clients, as well as the web interface.

I created a new instance of Nextcloud 17.0.3 using the dockerhub image and the same thing happens. One instance has 2FA enabled, the other doesn’t, and this doesn’t appear to matter.

The odd thing is that even after rejecting or timing out the login, logs from the server side show the iOS Nextcloud client accessing the data - it seems to run a series of PROPFINDs on file paths that exist on the server, indicating it is in some way logged in:

[01/Feb/2020:19:37:12 +0000] “PROPFIND /remote.php/webdav/my/file/path HTTP/1.1” 207 13880 “-” “Mozilla/5.0 (iOS) Nextcloud-iOS/2.25.5”

Having the same issue.
Have installed owncloud app and login is fine

For people having this issue: the UI says that the login failed, but it actually works under the hood, and the account is saved. Go to “Files” and access Nextcloud from there. You will see your files. Go back to the NextCloud app. You are logged in.

I have tested the above by uninstalling the app and installing it again. I reproduced exactly this behaviour: after login “failure” in the app, as soon as one has accessed nextcloud from the “Files” app, one is logged in in the “NextCloud” app.

Having the same issue…

I have the same error. I get 2 red windows with error NSHTTPURL_Response Code 401 and 415.

Same issue here…
But i got a 404 error first and second got 401,
in the log i got this error only:
Login failed: ‘XXXXXXXX-XXXX-XXXX-XXXX-FD82D80D1312’ (Remote IP: ‘123.123.210.195’) ( I changed the id and the ip too.)

Somebody can help?