Cannot login: Too Many Requests

Hi All, Any luck with the root of the issue, I’m in the same boat

Same problem here, only for 1 user and only from the android client (either from wifi or cellular network).
Nothing relevant in the log file.

Also seeing this on an iOS device, but not Android (or browser based though I’ve not seen anyone complain about this from a browser). If it makes any difference, I am using the Linuxserverio docker image and running NC 20.0.4.

I’m not quite sure what to look for in the logs, but the first seemingly related one looks like this:

[core] Warning: Login failed: '<user>' (Remote IP: '<ip>')

PROPFIND /remote.php/webdav
from <ip> at <date-time>

A couple of those follow by a bunch of:

PUT /remote.php/webdav/<...>

Which l think all correspond to an attempt to upload some photos (manually).

No security or setup warnings in the admin overview.

Has anyone managed to figure out what this is yet or how to work around it before a fix arrives?

2 Likes

Hi all,
I was having the same issue and I believe that it’s because I changed my user password in admin panel and did not update the android app login. I was having repeatedly failed login attempts.

I was able to get rid of the error message by deleting the content of the table "oc_bruteforce_attempts " on nextcloud database.
DELETE FROM nextcloud.oc_bruteforce_attempts

You can put a where clause and limit it by IP so that only your login attempts are deleted:
DELETE FROM nextcloud.oc_bruteforce_attempts WHERE ip ="X.X.X.X";

12 Likes

This solved it for me. thanks!

My guess the problem is, that after a password change, some app (in my case - android client) bursts attempts to login with the old password, which looks like a brute-force attack for the server, which locks out the IP.
It was no -docker situation. If it is like I think, a bug should be registered.

Deleting records in oc_bruteforce_attempts from database fixes it (untill next password change?). Thanks @jotatr.

FWIW there looks to be a new occ command in NC20 to address this without having to jump into sql commands:

security:bruteforce:reset

For the Linuxserverio docker, you’d want to bash into the container:

docker exec -it <container-name> bash

and run the command something like this:

sudo -u abc php /config/www/nextcloud/occ security:bruteforce:reset <ip>

I haven’t been able to confirm if this fixed it yet as the person who was affected by this uninstalled the app and hasn’t yet reinstalled, but I thought I would follow up with this method in case anyone else might find it simpler.

7 Likes

How did you solved ? We do not need know that you already solved or not. We need to know how did you solved

Same issue here. I think caused by the latest Android app update. It kept trying to tell me to “Grant Access” even though I’ve used the app on that device for months now. But, even trying web access from my laptop gave the same error so I had initially ruled that out.
The clues and solution found by @Da01W6hwz proved helpful to me with one nuance I think worth mentioning. In my case, the IP address was 127.0.01 which at first didn’t make sense to me. Then I remembered that my nextcloud is running on apache behind an nginx reverse proxy on the same host. So, all requests appear to come from the localhost regardless of where or what device they actually originated. Hope this helps someone.

I deleted everything in the oc_bruteforce_attempts table and now it works.

Was there anything in that table that I maybe should not have deleted?

2 Likes

thanks this helped me with this problem

On a snap install,
sudo /snap/bin/nextcloud.occ security:bruteforce:reset 127.0.0.1
solved the issue (culprit was also the nextcloud smartphone app, after a password change).

8 Likes

I run from a Truenas and the DELETE command does not work! Any idea for help (as I don’t know such things…)

Need help… going around in circles. Using Truenas, which really wont let me do anything much. How do I find this oc_bruteforce_attempts file?

You’ve to check out what database you’re using. In case you’re using mysql/mariadb you’ll find the solution above. Just delete everything in oc_bruteforce_attempts with
delete FROM oc_bruteforce_attempts;
Please be sure you’re able to do that in a proper way …
It would be very nice to have an occ command to list the offending IPs and to delete all or a selection. The situation at this time is horrible!

4 Likes

Thanks heaps. This should really be easier to discover. What happened my end is I changed my Nextcloud password. Then my clients of course stopped working so I had to reconnect them. I made a few mistakes along the way and looks like I tripped this bruteforce detector. I’d like, as admin to recent emails when bruteforce login efforts are rejected!

Odd, I had this issue, but I didn’t change my password. I did the same fix you did, it works.

Having the same issue with my dockerized NC 22 install now, non of my account’s passwords were changed recently however.

This almost drove me nuts. I set up a new NC installation, with the same old domain, but did not restore the old accounts. So, 3 phones 3 computers with all the DAVx5, NC clients etc. tried to log in with invalid logins, so… I get locked out.

Although the posts above are somewhat helpful, not one presented me with the detailed solution, step-by-step.

Therefore, for those beginners like me,

Below is how I solved the problem on any Debian/Ubuntu based nc installation.

(Should work for NCP, NC-TurnKey LXC on Proxmox, etc.)

  1. Logout from all your clients (mobile/desktop/CalDav etc.

  2. Go to any “show my IP” homepage to see what IP you currently have (or use the terminal, router, or, and… and and… many ways to find out your IP)

  3. then go to the terminal of your Nextcloud instance and use the following command to reset your IP’s login attempts:

sudo -u www-data php /var/www/nextcloud/occ security:bruteforce:reset 0.0.0.0

Note: replace 0.0.0.0 with your IP address.

That should solve it.

if your have NC installed as a snap see this post below

7 Likes

This worked for me also.
I am running NC on a Raspberry Pi in my home LAN (no outside access). I added an SD card for data storage. I messed up the reconfiguration of the data directory to the SD card, so I uninstalled and reinstalled (using snap again). Got the SD card working for the data repository. Then my android wouldn’t log in (too many attempts). I ran this command and it worked!
Thanks.