Cannot login to admin account due to "secsign id" removal!

I configured "secsign id " so its worked properlly
after i disabled it from admin account, now i cant login to my admin account.The error will comes,

Two-factor authentication

Could not load at least one of your enabled two-factor auth methods. Please contact your admin.

Two-factor authentication is enforced but has not been configured on your account. Contact your admin for assistance.

how can i fix this .
now i cant login to admin account!
i appreciate replies ,thank you

It has never been a good idea to force 2FA authentication and then disable the required service without making sure that a backup way exists :wink:

What about the twofactor_backupcodes app, have you disabled it too?
You can try to access your server using ssh and creating a one time backup code (occ twofactorauth:admin:generate-code ...) or enabling at least one 2FA service using the occ command line tool (occ app:enable ...).

thank you for your respond
i typed this code " occ twofactorauth:admin:generate-code" but its not working for me
the nextcloud is running on a freenas

You usually have to use sudo to execute the occ command in the Nextcloud document root. The occ command description can be found in the administrator guide.

is there any other way to do this thing
i tried occ command but its not working ,i already run it as sudo ,but the command is not working. i think the problem is ,its on a freenas box

No, there is no way to do it differently. Why should Nextcloud behave differently on a FreeNAS? Have you used the search function of this forum to get information how to call the command on a FreeNAS system?

I would recommend, that you

  1. check where the occ command exactly resides.
  2. check if execute rights are set, if not use sudo with php to call it.

Thanks for your help,
i fixed it up,
i ceated new admin user through occ command and i enabled secsignid again.
After that disabled it properly
now everything is fine ,thank you.
Love nextcloud!

1 Like