Cannot install NCP on RPi4 using install.sh - distro not supported

As my ncp docker container was destroyed again, I wanted to try out the more native version of ncp. I therefore tried to install using
# curl -sSL https://raw.githubusercontent.com/nextcloud/nextcloudpi/master/install.sh | bash

After it installed some packages, I get the following error:

ERROR: distro not supported:
Raspbian GNU/Linux 10 \n \l

This is my system:
cat /etc/os-release

PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"                                         
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs" 

What’s the big deal? https://ownyourbits.com/nextcloudpi/#content_start says that “Buster” was supported?!

Please lend me a hand to get this thing up and running again asap - I need it for family and primary for work purposes. Thank you very much!

Greets

Can you check what’s in there:
etc/ncp.cfg

here is the check function:
https://github.com/nextcloud/nextcloudpi/blob/c9610e4d5c90888334047f82ab8086a0c9e77cc3/etc/library.sh#L403-L409

Not sure if this jq-command is available, so you could run it in a terminal.

Thank you for the reply. I found another thread, mentioning that one should use bullseye now. So I dumped my install, put the latest RPi image on the sd-card and tried again.

This time, it kinda went through. But at the end, I get another error:
E: The value 'bullseye-security' is invalid for APT::Default-Release as such a release is not available in the sources

So, is it even installable at the moment??

Edit: I use my RPi as a headless server. So, I’m bound to the terminal.

Greets

Got myself an answer from GitHub. Man, info is scattered all across platforms.

https://github.com/nextcloud/nextcloudpi/issues/1437#issuecomment-1061641841

Now let’s see, if it runs though.

Too bad, doesn’t work out, because install.sh wants to force installation of old PHP packages. Unfortunately, this seems to hinder samba installation. This is a mess :-/

After trying over again a few times, it went through the installation process. This gives me the thrills.

It’s a practical setup for raspberry pi. It’s mainly one person writing all the scripts, and then some community around it to do support, documentation, translation, … Don’t expect everything to be perfect and to cover all cases of setups. However, it helps less experienced users to have a decent setup and to get some reasonable performance out of a small and cheap device.
If you know better, and you have ideas for improvements, contributions are welcome.

I didn’t know that. Thanks for the clarification.

Hey, how did you fix those samba problems? It seems I ran into the same issue. You just mentioned you “tried over again a few times” and that was marked as solution.

If I’m not mistaken, it worked after reinstalling the latest 64 bit RPi image. But I had to go back to the Docker image anyway, because NC refuses to redirect the data folder to my NFS mount. Therefore, it seems like I’m bound to Docker.

Thank you for your quick answer. So you just downloaded the newest bullseye image, set that up and downloaded NCP the common way and it worked?

Yep, that’s how I was able to install NCP.

Strange because I keep running into the same issues even with the newest bullseye image. Well, it’s been 18 days so maybe something has changed from your approach to mine now. Thank you for your help anyway.

1 Like