Cannot install Desktop client via ppa on Ubuntu 21.10

I am trying to install nextcloud client via ppa on Ubuntu 20.10. However, when issuing apt install nextcloud-client I get the following error:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 libqt5sql5-sqlite : Depends: libqt5sql5 (>= 5.10.0) but it is not going to be installed
                     Depends: qtbase-abi-5-12-8
 libqt5websockets5 : Depends: qtbase-abi-5-12-8
 nextcloud-desktop : Depends: qml-module-qtqml-models2 but it is not going to be installed
                     Depends: qml-module-qtqml but it is not installable
                     Depends: libqt5webenginecore5 (>= 5.7.1) but it is not going to be installed
                     Depends: libqt5webenginewidgets5 (>= 5.7.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Any suggestion on how to fix the issue?

PS: I tried also via snap but I get basically the same error.

It is an Ubuntu issue. You’ll need to figure out how to resolve the unmet dependencies. Easiest way is search the exact errors it is showing you, adjusting words as needed.

Thank you for the reply.
Do you have any suggestion on where to start?

Yeah, didn’t you see the link above to fixing unmet dependencies in Ubuntu? Here it is again.

Sorry, I completely missed the link. I tried all the methods listed in the page but none of them is working. Any other suggestion?

Problem solved, I used the beta version of the package.