Cannot get to "All files" after 13.0.6 -> 14.0.1 upgrade

Nextcloud version 14.0.1.1:
Operating system and version CentOS 7:
Apache or nginx version Apache 2.4.6:
PHP version 7.2:

Upgrade from 13.0.6 to 14.0.1 went smoothly, However login in via the web interface gives an infinite spinner while trying to load “All files” (/apps/files/).

Navigating to the gallery or shared folders works and I can see files there.

Desktop and Android clients seem happy and are able to list files.

I have tried to removed the APC cache line from config.php -> No change

The output of your Nextcloud log in Admin > Logging:

{"reqId":"W6vfEPpeWendkg3Kabw1vgAAAAY","level":0,"time":"2018-09-26T19:33:36+00:00","remoteAddr":"A.B.C.115","user":"patrick","app":"no app in context","method":"GET","url":"\/apps\/files\/","message":"No cache entry found for \/appdata_xxx\/avatar\/patrick\/avatar.jpg (storage: local::\/mnt\/nextcloud-data\/, internalPath: appdata_xxx\/avatar\/patrick\/avatar.jpg)","userAgent":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/69.0.3497.100 Safari\/537.36","version":"14.0.1.1"}
{"reqId":"W6vfEPpeWendkg3Kabw1vgAAAAY","level":0,"time":"2018-09-26T19:33:36+00:00","remoteAddr":"A.B.C.115","user":"patrick","app":"no app in context","method":"GET","url":"\/apps\/files\/","message":"No cache entry found for \/appdata_xxx\/theming\/images\/background (storage: local::\/mnt\/nextcloud-data\/, internalPath: appdata_xxx\/theming\/images\/background)","userAgent":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/69.0.3497.100 Safari\/537.36","version":"14.0.1.1"}
{"reqId":"W6vfEIhekB5yKaTp-Zn-BgAAAAM","level":0,"time":"2018-09-26T19:33:36+00:00","remoteAddr":"A.B.C.115","user":"patrick","app":"no app in context","method":"GET","url":"\/css\/icons\/icons-vars.css","message":"No cache entry found for \/appdata_xxx\/css\/icons\/icons-vars.css.gzip (storage: local::\/mnt\/nextcloud-data\/, internalPath: appdata_xxx\/css\/icons\/icons-vars.css.gzip)","userAgent":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/69.0.3497.100 Safari\/537.36","version":"14.0.1.1"}
{"reqId":"W6vfECYA9M8A2BvHgMa3dQAAAAE","level":0,"time":"2018-09-26T19:33:36+00:00","remoteAddr":"A.B.C.115","user":"patrick","app":"no app in context","method":"GET","url":"\/avatar\/patrick\/64?v=0","message":"No cache entry found for \/appdata_xxx\/avatar\/patrick\/avatar.jpg (storage: local::\/mnt\/nextcloud-data\/, internalPath: appdata_xxx\/avatar\/patrick\/avatar.jpg)","userAgent":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/69.0.3497.100 Safari\/537.36","version":"14.0.1.1"}
{"reqId":"W6vfEYhekB5yKaTp-Zn-DQAAAAM","level":0,"time":"2018-09-26T19:33:37+00:00","remoteAddr":"A.B.C.115","user":"patrick","app":"no app in context","method":"GET","url":"\/apps\/gallery\/config?extramediatypes=1","message":"No cache entry found for \/patrick\/files\/gallery.cnf (storage: home::patrick, internalPath: files\/gallery.cnf)","userAgent":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/69.0.3497.100 Safari\/537.36","version":"14.0.1.1"}

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => 'XXX',
  'passwordsalt' => 'XXX',
  'secret' => 'XXX',
  'trusted_domains' => 
  array (
    0 => 'cloud.domain.com',
  ),
  'datadirectory' => '/mnt/nextcloud-data',
  'overwrite.cli.url' => 'http://cloud.internal.local',
  'dbtype' => 'mysql',
  'version' => '14.0.1.1',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'nextclouduser',
  'dbpassword' => 'XXX',
  'installed' => true,
  'trusted_proxies' => 
  array (
    0 => 'X.Y.Z.5',
  ),
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'loglevel' => 0,
  'updater.release.channel' => 'stable',
  'htaccess.RewriteBase' => '/',
  'maintenance' => false,
  'theme' => '',
  'mail_from_address' => 'cloud',
  'mail_smtpmode' => 'smtp',
  'mail_smtpauthtype' => 'PLAIN',
  'mail_domain' => 'lesz.ch',
  'mail_smtphost' => 'XXX.local',
  'mail_smtpport' => '25',
  'enabledPreviewProviders' => 
  array (
    0 => 'OC\\Preview\\PNG',
    1 => 'OC\\Preview\\JPEG',
    2 => 'OC\\Preview\\GIF',
    3 => 'OC\\Preview\\BMP',
    4 => 'OC\\Preview\\XBitmap',
    5 => 'OC\\Preview\\MP3',
    6 => 'OC\\Preview\\TXT',
    7 => 'OC\\Preview\\MarkDown',
    8 => 'OC\\Preview\\Movie',
  ),
  'updater.secret' => 'XXX',
);

I had similar errors in the RC-version:

However, they said that the issue was probably solved and the corresponding fix went into NC 14.0.1, so you shouldn’t see this error. Either it isn’t fixed or this is a different issue. Please report to the developers on github.com/nextcloud/server/issues

It might be worth checking the apps you have on your system. For me it helped a lot, to disable those not compatible with NC 14 yet.

Thanks for the quick response.

I have now opened issue #11405 with some more details.

Regards, - Patrick -

For anyone having such issues. In my case it was caused by a folder name starting with ‘%’.

I think it will get fixed soon, renaming such folders is the only option for now.

2 Likes

I also had this problem, and found a ‘%’ sign in the middle of a file name. Once I removed the % from the name, the files listed as normal.

File name:

17554192_1951598098405814_2169164917023346117_n.jpg (JPEG Image, 480 × 448 pixels) - Scaled (141%)

Changed to:

17554192_1951598098405814_2169164917023346117_n.jpg (JPEG Image, 480 × 448 pixels) - Scaled (141)

Same here. Only happens with Internet Explorer. Chromium and Firefox are doing fine.
I deleted all %-Signs but the problem remains.

Any suggestions?