Cannot get onlyoffice integrated with NC. Please help

I have never seen onlyoffice in action. Decided to give a shot and tried to install but failed.

I have an unRAID machine. nextcloud (13.0.1) docker is installed and working in connection with nginx-letsencrypt docker. onlyoffice docker is also installed and working at https://only.mydomain.com. The onlyoffice app is also installed on NC and pointed at the onlyoffice server.

It seems all OK so far. But, NC gives me “Requests to the server have been blocked by an extension.” error when trying to use onlyoffice.

By the way, I am using nginx file within letscrypt docker (unRAID box running on 192.168.1.100) what @Schmu advised in one of his previous posts:

server {
listen 443 ssl;
server_name only.mydomain.com;
server_tokens off;
include /config/nginx/ssl.conf;

add_header Referrer-Policy “no-referrer”;

add_header X-Frame-Options “ALLOW-FROM https://cloud.mydomain.com/” always;
add_header X-XSS-Protection “1; mode=block”;
add_header X-Robots-Tag none;
add_header X-Download-Options noopen;
add_header X-Permitted-Cross-Domain-Policies none;

location / {
proxy_pass http://192.168.1.91;
proxy_redirect off;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Host $server_name;
}
}

On the server onlyoffice resides which is a CentOS machine running on 192.168.1.91:
include /etc/nginx/includes/onlyoffice-http.conf;

server {
listen 0.0.0.0:80;
listen [::]:80 default_server;
server_tokens off;

include /etc/nginx/includes/onlyoffice-documentserver-*.conf;
}

I would appreciate any help. Thanks.

same problem here! I even tried installing onlyoffice on a local domain and vps… both have the error

Hi,

I didn’t write that in my advise though :wink:

My config only works with https://192.168.1.91;

location / {

proxy_pass         https://192.168.1.91;

There is probably a way to have only http as internal connection, but I have no idea how to do that. For this exact configuration that I suggested however, it has to be https, otherwise the connection will be blocked.

It’s weird… I set up a vps and got onlyoffice to work --> docu.makkubeiji.tech

but when I put that in my nextcloud config it doesn’t work… lmao, it shows “Requests to the server have been blocked by an extension.”

That means you configured your proxy pass to https and in the Onlyoffice app you also configured the https address of onlyoffice?
As far as I know when using HTTPS it is important to have HTTPS active and working pretty much the whole way from the client, through nextcloud and to onlyoffice.
So maybe you can check, that there is no http address configured somewhere (in the app and in the https part of your nginx config).