Cannot get external storage Webdav - IIS working properly

I installed a fresh Ubuntu 20.04 VM and the latest Nextcloud via Snap.

I also have a Windows 2019 x64 server configured with IIS + Webdav.
(Filezilla FTP server working way too slow and can’t get Samba support activated)

First added everything just using port 80 and no certificate.
It seemed to work until i started to use the nextcloud client for Windows.
The client got sync problems , HTTP transmission issues, in the log i can see Sabre errors that external storage with mount id … is unvailable (while it should be)

I tried several solutions and manipulations but i cannot get it fixed.
It seems that using webdav with https / certificate would fix things.

I tried with a self-signed certificate and using a windows standalone CA.
After adding the certificates to Ubuntu and update-ca-certificates i just keep getting :

So i checked if i installed the (.pem to .crt) files correctly and i did because “sudo openssl s_client -showcerts -connect” confirms connection and verification…

It seems like nextcloud or the external storage app isn’t picking up the CA certificates or just not allowing anything else then a public CA ?

All i wanna do is use Nextcloud to access a lot of local Windows shares, it’s almost all i need.
Before i used a full manual setup of nextcloud and had Samba support, but after being unable to use the updater anymore i was forced to make this new installation.

Any help is welcome :slight_smile: